How to disable preload for certain files / program?

Hi,
Is there a way to disable preload for a given process and/or a set of files?

I’m having an issue with MLDonkey, which I configured to run as a service. Apparently, preload is trying to pre-load the temporary files lying under MLDonkey working directory (which are huge), and tis is causing a massive slowdown when booting…

Best regards,
Eduard

What do you mean by ‘configure it as a service’ ? You mean you run it at boottime with root permissions?

Yes, although not as root but as an unprivileged, special user. I’m not that crazy…

By the way, this is how MLDonkey is used in every distro I’ve seen. I don’t know why OpenSUSE doesn’t provide the init.d script for doing it that way, but that’s really a whole different debate in which I’m not interested at all right now…

Anyway, what I need is precisely avoid preload daemon to precharge the big, temporary download files that MLDonkey opens at its startup.

Regards

Nobody…?

I guess it must start sometime. When do you want it to start?

Sorry, maybe I’m not explaining it correctly…

I don’t want to disable “preload” service, or to make it start at a different time.

What I want is to make preload stop “preloading” files for MLDonkey service, as these are really huge and cause a big memory consumption which causes a big slowdown at system start.

Just for the sake of knowing if I’m being right, this is what I just understand about preload. Please, correct me if anything is wrong:

  • “preload” service starts early at boot time, then monitorizes files opened by any subsequent service started.
  • on subsequent boot cycles, “preload” uses the previously stored file list to “pre-cache” these files in memory, so services can start faster.

This is just fine. Problem is, MLDonkey files are, as you might imagine, movies, TV shows, etc…, so we are talking about huge files here. As I’m starting it as a service, I guess “preload” is just trying to cache these, which, instead of generating a performance boot it causes quite the opposite (a big slowdown).

What I’d like to know is: is there a way to SELECTIVELY disable preloading for a specific process and / or a set of files? I mean a sort of blacklist or whatever so preload just ignores those when analyzing boot file accesses, so it doesn’t attempt to precache them later.

I hope it’s clearer now :).

regards

bump

(last bump before definitely giving up…)

You can’t(Well not that I can see) look into it it creates a session profile then creates a file. Look at /var/cache/preload/prepared I guess in theory you can look at that and take them out, but I’m not sure how or when the cache is created.

You have a prepare_preload(read it perhaps you’ll get some further insight) which can create one but I’m not interested in this. So perhaps with some of the above you can take it further.

Ok, thanks, I’ll give it a look. Maybe I can customize the script to filter out P2P files, which is really what I need.

Thank you very much,
Eduard

P.S grep is your friend was how I got to some bits I then googled a bit and queried the rpm db but it is a little sparse on info. I’m not sure but I don’t think this is the preload you find from google but rather a suse version. Though I could be wrong if so surprised at the lack of upstream from the rpm.

Well, finally solved it, with a very simple command:


sudo zypper rm preload

Cheers
Eduard