How to disable/mute event sounds?

Trying to figure out where the proper place to disable or lower volume for event sounds is located? Leap 42.1 KDE user here, and trying to lower volume from lower taskbar doesn’t seem to “stick” / work, I pull the tick down to bottom or click on speaker icon to disable it/mute it, and it doesn’t “stick”. It keeps going back up to full volume again…I right click on speaker icon, and choose “muted”, and it doesn’t check the box and make it “stick” / muted option enabled. Something isn’t right here, and not sure where else to disable/mute it at?

That’s the master volume.
And PulseAudio by default likes to manage that itself and basically ignore what you set.

You have two options:

  • To just turn off event sounds, run KMix (you probably have to install that first), its volume control has a dedicated “Event sounds” volume slider which you could drag down. Maybe there’s a similar option in KDE’s (now) default volume control applet, I’m not sure at the moment, try to right-click on it and choose “Volume Control Settings”.
  • set “flat-volumes = no” in /etc/pulse/daemon.conf. This will force PulseAudio to not modify the master volume, so if you mute it, it stays muted.

So much work for something that shouldn’t be so difficult to change with controllers installed by default lol. I’ll have to try some stuff you suggested then, cause currently after fresh installation, I’m not even seeing the “Event Sounds” in the taskbar for speaker volume now, where it had been displayed before lol. Hmm…

Install pavulcontrol program it is much easer to use then kmix or/and you can install veromix which can live in the system tray. Any allows you to control each applications volume independent of any other app.

Thanks Gogalthorp, will try one of those! :slight_smile:

Edit: Veromix doesn’t appear to be released for Leap yet for one click installer, but first one suggested seems to have one click installer for Leap. I tried searching for both in Software Management and didn’t show any results for either, weird lol

Edit 2: Not sure where it’s located? pavulcontrol, but can’t seem to find for event sounds either any where… searching for “pavulcontrol” in menu search don’t bring results.

typo sorry is pavucontrol

Should be available

not sure about veromix in 42.1 but the full package name is plasmoid-veromix

But the kmix in 42.1 seems to be improved from 13.2

Ah okay, yeah, I searched google and found this one and installed it: but searching in menu search for correct spelling one still don’t show anything. I’ll try searching in software manager once though, and see if it’s showing up, and maybe reinstall from software manager instead of one click installer.

Edit: When I open that up, it doesn’t list “Event Sounds” in there either…? Lol.

Ok, I’ll try searching software manager for that as well, cause after googling, the one here doesn’t seem to list Tumbelweed nor Leap for compatibility, just opensuse 13.1 and 13.2 lol.

Nice, if the first two don’t seem to help or whatever, I’ll try that as last resort lol

Actually, KMix seems to be installed already…when i open it up, move the thing to bottom to mute it, still doesn’t “stick” off/muted…

Veromix is a KDE4 plasmoid and hasn’t been ported to Plasma5 yet AFAIK.
IOW, it won’t work.

But the kmix in 42.1 seems to be improved from 13.2

No, it’s exactly the same.

Which thing do you move down?
You should use the right-most slider, labelled “Event sounds”…
If that doesn’t help, you probably should mention what event sounds exactly you want to mute…

For every application a slider should show up in KMix (and pavucontrol and the volume applet), with which you can control the volume for that application. But it only shows up while that application is actually playing a sound…

Plasma5’s new volume control applet only shows the master volume when you click on it.
To get the full controls you have to right-click and choose “Volume Control Settings”, as I wrote.

Well like you said, there’s basically a second black speaker icon show up with “Event Sounds” in it to far right side when I click on speaker icon. Those annoying BLINGS/ RINGS when a small confirmation prompt pops up, like confirming when you want to move a file, delete file, or when there’s new updates to install. I then go and move slider down, and minimize the speaker icon setting thing / click on taskbar some where and it’s back up again full volume, it doesn’t stay down to bottom / volume slider doesn’t stay to bottom for it being muted, nor does it do anything when I right click on “Event Sounds” and choose “Muted”. Also, when there’s volume sliders for other things, clicking the little speaker icon under each one would mute it, but when I tried that with Event Sounds it doesn’t work. This is probably a bug.

Yeah, right clicking on the main black speaker, I choose “Audio Volume Settings” and “Event Sounds” isn’t listed in there any where. Nothing under “Applications” “Recording” “Output Devices” “Input Devices” “Configuration”.

Regarding muting not working, it did this last time I had the event sound go off for deleting video from USB stick. Another speaker icon showed up in taskbar, and had for event sounds, clicked on little speaker icon at bottom of slider and it went to “red” color… so it disabled/muted.

You mean you got a separate slider for the event sound in KMix only while the sound was playing?
Sounds like you are using the VLC backend. Due to limitations in VLC itself, it doesn’t support event sounds volume control.
Better uninstall it, it has other limitations/problems as well (like raising the master volume to 100% when the first event sound is played after login), and stick to the default gstreamer backend:

sudo zypper rm phonon4qt5-backend-vlc

Well, I’m not sure to be honest, but there’s two little black speaker icons in taskbar still, one that’s been there since the install of OpenSuse Leap. Shows two for playback devices, and one below for Capture Devices, doesn’t show slider for Event Sounds in there. The second black speaker icon showed up before by itself after I got a prompt window popup asking if I’m sure I wanted to delete file (which also makes a chime/ding-a-ling sound from event sounds). It’s still displaying there and one to the right of it for VLC player volume. So two “Built-in Audio Analog Stereo” sliders on left side, then a separator skinny bar vertical with Event Sounds and VLC Player audio stream on right side, with “Mixer” button below them and “configure channels” beside that “Mixer” button to right of it. If you want, I can take screen shots? I can try to uninstall that though too I guess. Or just wait 9 hours (would be about 7am my time/Eastern Standard Time USA) and do fresh install anyway… And write down my steps specifically.

Yes, the one that was there before already is Plasma’s Volume Control applet, the other one is KMix which you started manually.

To get rid of one, either quit KMix, or disable the Volume Control in the “System Tray Settings”.

So two “Built-in Audio Analog Stereo” sliders on left side, then a separator skinny bar vertical with Event Sounds and VLC Player audio stream on right side, with “Mixer” button below them and “configure channels” beside that “Mixer” button to right of it.

Yes, that’s KMix.
And the VLC Player audio stream indicates that you do use the VLC backend.
So uninstall it, it’s “broken”. (it doesn’t mark event sounds as “Event sounds”, so the corresponding volume is not used; this causes the effect you noticed)

As mentioned, the package is phonon4qt5-backend-vlc, but also uninstall phonon-backend-vlc if you have it installed to be sure (that’s the KDE4 version).

Right, I remember opening Kmix one to see if Event Sounds was there, and it was, so muted it there.

Okay, thanks Wolfie. :slight_smile:

Oh okay, will do, I’ll do fresh install of Leap today after doing some yard work and keep that in mind, thanks again. :slight_smile: