How to disable automounting in 13.2?

I disabled automounting in previous versions of OS successfuly but this time I don’t have a clue how to do it?

Whenever I plug in USB drive it is automounted – in my case it is not desired effect. I would like to mount and unmount device manully only.

So how to disable automount?

I already have file

/etc/udev/rules.d/85-no-automount.rules

with content

SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}="1"

You need to tell us which desktop you are using.

I’m using KDE, and it has never automounted anything, though I think I know how to configure it to do that.

This is a function of your desktop environment – whatever that is.

Thank you for your answer. I was using previous OS (11.4) for so many years that I forgot where and what I set up :slight_smile: I use KDE 3.5.10 (no joke).

It should not be automounted you will get a notice and if you use the device and options if don’t select an option no mount. If you need some security on usage look at configure desk top - Removable Devices. several options there and that is where you would turn off the mount if that is on. Also device action may help. If not tell us what you want or need to happen.

@gogalthorp](https://forums.opensuse.org/member.php/37208-gogalthorp) I am unable to understand the sentences you wrote.

Ok simple steps

  1. open Configure Desktop
  2. look at device actions and removable devices
  3. If they don’t provide what you need tell use exactly what you need

Default an inserted device is not auto-mounted. It is mounted if you choose to open it in anyway don’t open it won’t be mounted.
remove the device action associated with USBs and won’t mount any way but command line or if you browse for it. Or more drasticly you can remove the dev notifier. With out know exactly what you want to accomplish we have no way to know exactly how to help but point you to existing tools.

Done.

There is no such thing.

After some googling I sense I am (and days of KDE 3.5.10) doomed – KDE assumed and relied on existence of HAL.

So if automounting is desktop environment responsibility it might be the case for KDE 3.5.10 it is no longer solvable.

I’m wondering if perhaps

SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}="1"

might need to be

SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}:="1" 

just in case some other rule is changing the device property value later.


":="Assign  a  value  to  a key finally; disallow any later changes.

Oh dear I missed that you were running KDE 3.5. I got no idea. In 4.X it is default not to mount on insertion.

IMO you might have more success asking your question in the KDE forums since I doubt that KDE 3.5 would be using something in a modern openSUSE to mount (although who knows? Could someone have built some kind of kludge up to 13.1 to emulate a HAL when it should have been removed long ago? If some kludge existed, then maybe the solution might be to install 13.1 with KDE 3.5, then upgrade to 13.2).

In the meantime, there is one possible Google hit,

My recommendation is…
If your primary concern is using KDE 3.5 apps, AFAIK you can still install those apps in a KDE 4.x environment. You’d be running KDE 4.x with all its improvements and goodness (stable for some time now) but you can run your familiar legacy apps. If you do this, then you should be able to disable automounting using KDE 4.x methods.

HTH,
TSU

In the meantime, there is one possible Google hit,

No, that group is not used with openSUSE.

My recommendation is…
If your primary concern is using KDE 3.5 apps, AFAIK you can still install those apps in a KDE 4.x environment. You’d be running KDE 4.x with all its improvements and goodness (stable for some time now) but you can run your familiar legacy apps. If you do this, then you should be able to disable automounting using KDE 4.x methods.

HTH,
TSU

Yes, much of the eye candy/effects can be removed and the desktop display made to emulate KDE 3.X. behaviour in KDE 4.x, so it’s the approach I’d take if I wanted to maintain a legacy look and feel.

After reading the following HOW-TO-KDE-3-5 on openSUSE 12-1, I not e that it is mentioned

IMPORTANT: in Yast > System > System Services, turn ON/YES “haldaemon”. Without this, CD’s, DVD’s, USB sticks may not be recognised when inserted.

so this suggests it is as simple as disabling ‘haldaemon’. (I recall that KDE3 users were still required to use it for auto-mounting, and so it is still available for that reason.)

On 2015-01-04 01:26, tsu2 wrote:
>
> IMO you might have more success asking your question in the KDE forums
> since I doubt that KDE 3.5 would be using something in a modern openSUSE
> to mount (although who knows? Could someone have built some kind of
> kludge up to 13.1 to emulate a HAL when it should have been removed long
> ago? If some kludge existed, then maybe the solution might be to install
> 13.1 with KDE 3.5, then upgrade to 13.2).

There is an optional ‘hal’ in 13.1 (KDE:KDE3). I don’t have a running
13.2 right now to check, but as KDE 3 is part of the official openSUSE
13.2 distribution, they surely found a way. Also, notice that ‘hal’ is
not in ‘oss’, thus I infer that the distribution KDE-3 does not need ‘hal’.

> My recommendation is…
> If your primary concern is using KDE 3.5 apps, AFAIK you can still
> install those apps in a KDE 4.x environment. You’d be running KDE 4.x
> with all its improvements and goodness (stable for some time now) but
> you can run your familiar legacy apps. If you do this, then you should
> be able to disable automounting using KDE 4.x methods.

Some KDE3 apps really need KDE3 libraries and tools.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Thank you. I installed hal as well, but so far – no luck.

Did you try disabling the haldaemon service as I mentioned as well? AFAIU, KDE3 uses that mechanism for auto mounting.