How to diasable filesystem checks on boot?

How to diasable filesystem checks on boot?

Destroying your system seems to be fun for you, huh? What’s next? Would you like to know how to create an open relay or how to become a drone in a botnetwork?

Anyway, paste the thread-title to google, add the word “Linux”, correct the word “diasable” and you’ll find answers.

Here’s the exact procedure: → click.

Ansus wrote:
> How to diasable filesystem checks on boot?

what are you experiencing which you are wanting to change?

normal boot file system checks take less than a second (looks at a
“dirty bit” i think, and moves on)

are you instead seeing a lengthy fsck on every boot?

fyi, a default install of openSUSE has no such time consuming
fsck/file system check on every boot…instead it forces a check
once each 60 days…

on the other hand, if you shut down incorrectly/uncleanly or (say) the
previous session crashed…then a file system check is required

i say ‘required’ but actually only necessary if you wish to use the
system again…do you?

if the symptom is fsck on every boot, then you need to fix the problem
causing that symptom–rather than remove the pain of the symptom
(skipping the required check)…


palladium

fyi, a default install of openSUSE has no such time consuming
fsck/file system check on every boot…instead it forces a check
once each 60 days…

In fact it checks about every 20 boots and usually in moments when I hurry to boot. If to cancel checks, some disks left unmounted, fuse does not load, as such ftp shares do not mount etc, so a lot of manual work to bring it to desirable state.

Destroying your system seems to be fun for you, huh? What’s next?

I can manually check any disks when I have enough time.

Please tell me how to disable that annoying fsck on boot.

Thank you. Just tried tune2fs -i 0

You shouldn’t disable filesystem checks at boot. As palladium states, the default is ‘force after 60 days of non checking’. If it is done before by the system, it has found some need for it, which could be FS errors, but a degrading condition of a disk as well.
Turning them of therefore indeed is a dangerous thing. For your own sake, please think it over, read some info. It will definitely get you into trouble one day. I know from experiences some years ago.

Ansus wrote:
> Please tell me how to disable that annoying fsck on boot.

disabling automatic file system repair functions triggered by actually
detected system anomalies will only further damage your system…

and will cause more (not less) time be taken exactly when you are in a
“hurry to boot”…

i just will not help you further damage your system–other than this:

that “annoying fsck on boot” is a symptom of an underlying problem…

FIX THE PROBLEM and the fsck on boot symptom will go away.


palladium

You didn’t mention which filesystem?

Whenever you are looking for something, take a keyword
and at the Konsole type “man -k keyword”. Sometimes you have to grep it, for example “man -k filesystem|grep -i ext”.

I think others have already answered your question.

This is a secondary disk with my former system (Ubuntu) installed, which I generally do not use. So I do not need to check it daily.

Ansus wrote:
> This is a secondary disk with my former system (Ubuntu) installed, which
> I generally do not use. So I do not need to check it daily.

let me try one more time:

daily forced fsck checks are not normal!

therefore i ask: why are they occurring on your machine?
how are you shutting down?


palladium

With shut down option in the Gnome main menu.

As palladium said, daily fscks are highly unusual, they only occur after a certain number of reboots or when your disks and / or filesystems are suffering from heavy damage. You should run fsck from a live-system and also check your disks physically, for example with s.m.a.r.t. or a tool from the manufacturer of your HDs. There seems to be something wrong, at least with the filesystem.

Seems tune2fs -i 0 does not work. It just tried to check my secondary disk which I do not use generally, again. If to interrupt it with Ctrl+C, it does not load a number of services such as Fuse and the host has no name after boot. So I have only one choice - is to remove the disk physically from the computer not to waste time to those useless checks >:(

tune2fs shows check interval 0:

Check interval: 0 (<none>)

Nevertheless it still checks the filesystem!

Ansus wrote:
> So I have only one choice - is to remove the
> disk physically from the computer not to waste time to those useless
> checks >:(

no, you have at least one other choice:

find and fix the problem which is causing the required checks (the
checks which are NOT normal and the rest of us are NOT having)


palladium

Well it has been said enough times in enough ways , I am going to
say it again any way ! If fsck wants to run there IS a reason and that is what needs to be found and fixed.

At a minimum download the disk checking utilities from the disk manufacturer and run those,

If that checks out OK,

and you still can’t find the problem,

ensure your backups are good.

I have found a solution which makes it possible to skip a forced file system check (instead of disabling fsck at all):

As root edit these two files (both of them!):

/etc/init.d/boot.rootfsck
/etc/init.d/boot.localfs

Look for this line:

FSCK_RETURN=$?

and after this one add these lines:

if test $FSCK_RETURN -eq 32 ; then
[INDENT]FSCK_RETURN=0
fi[/INDENT]

Now when you are annoyed watching the message " … has not been checked … check forced" just press Ctrl-C. The check will be delayed until the next boot procedure (unless a real fs error has occured).

This works in my SuSE 11.1 and probably also in other recent SuSE systems.

i think you can use tune2fs to set after how many mounts or how many days the systems checks your file-system for errors. with the -f option and shutdown you can force skipping the fsck on next boot. however this method is not recommend

On 07/21/2010 12:23 PM, l1zard wrote:
>
> i think you can use tune2fs to set after how many mounts or how many
> days the systems checks your file-system for errors. with the -f option
> and shutdown you can force skipping the fsck on next boot. however
> this method is not recommend

The question should be stated “Which do I hate worse: Waiting for an fsck to
finish, or losing data due to the compounding of uncorrected errors?”

On 2010-07-21 17:23 GMT hatto wrote:

>
> I have found a solution which makes it possible to skip a forced file
> system check (instead of disabling fsck at all):

This is dangerous.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Minas Tirith))