How to create svg icons in 15.4?

Using KDE desktop.

When you run ‘create link to application’ the dialog has a button that enables you to select an icon. You can accept one of the system icons, or browse to somewhere where you may have created a custom icon.

On a 15.3 system, your custom icon can be either a .png file or a .svg file. On 15.4 this still works for png’s but not for svg’s. The custon svg icon appears on the dialog button , after you have selected it, but it does not appear on the desktop, only a default system icon appears. Forcing a screen redraw, or even a reboot, does not cause the custom icon to appear on the desktop.

So how to create custom svg desktop icons on 15.4?

Does it help?

Yes, that works! i.e. you have to manually edit your .desktop files to remove the extension of the svg icon file.

That’s clearly a bug. Does anyone know if it has been reported? If not, how do I report it? Looks like a KDE bug, rather than an openSUSE one.

You can write a bug report for openSUSE, but, like you I think they have to go upstream to KDE.

KDE is here: You can maybe check there first if there is already one about this.

Checking that site, I see that there are many similar unresolved issues regarding svg icons. Executive summary - KDE’s svg code is a stinking pile of ****. I don’t think adding another bug report will help.

In my particular case, there is no problem on 15.3, which runs plasma 5.18. But the problem is present in 15.4 which uses plasma 5.24. Is there a way to use plasma 5.18 in 15.4?

I use plasma 5.25, try to install opensuse argon

Thanks for the suggestion. An alternative to a complete argon installation is to upgrade an existing 15.4 installation as described here

And if you do it that way, make sure no non-standard repositories are enabled, not even packman.