How to create PV CentOS 5 DomU at OpenSuse 11 Dom0 ?

I’ve mounted loop rhel5.iso on /mnt01/tmp,
edited /etc/exports correspondently. Started nfsserver exporting folder /mnt01/tmp. I was unable to start virt-manager ( it collapses right away)
or command line utility virt-install.
It just was not on the system.
The only one Yast menu option “Create virtual machine” appeared to be alive. At final stage , like on RH systems , i’ve made input into “Network URL” :-
input was accepted by GUI tool followed
by immediate error message sound like
“instead of buffer or string instance was
Actually, i’ve tried to reproduce well known schema of creating PV DomU on RH Xen
systems (CentOS 5.1, Fedora 8) been done
successfully for many times and failed.
Absence of virt-install also seemed strange
to me ( -d option to debug). I was able only to create Solaris90 HVM DomU with the same GUI tool.

Not sure why you are trying to do it this way instead of using YaST > Create Virtual Machines ?

virt-install is not known to me (on openSUSE), but I think you are refering to vm-install?

I can’t really help out here other than suggesting to try the vm-install to create your vm configuration.

Hope that helps,

vm -install appears to be the same GUI tool as YAST Control Center->Virtualization->Create Virtual Machine.
When i submit Network URL:-
it gets accepted.

  1. - IP Address Dom0.
  2. nfsserver restarted.
  3. exported directory /mnt01/tmp
  4. ISO image loop mounted on /mnt01/tmp.
    When click OK:-
    Error “coercing to Unicode: need string or buffer, instance found” comes up.
    Terminal output:-

dhcppc1:/etc/xen/isos # df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda10 20G 12G 6.9G 64% /
udev 2.0G 264K 2.0G 1% /dev
/dev/sda11 9.9G 183M 9.2G 2% /home
gvfs-fuse-daemon 20G 12G 6.9G 64% /root/.gvfs
4.2G 4.2G 0 100% /mnt01/tmp
dhcppc1:/etc/xen/isos # vm-install
ERROR VM creation job failed: coercing to Unicode: need string or buffer, instance found

Thank you

I’ve tried to consult the link at regarding RH paravirtual machines and found empty page:-
Novell Documentation

OK. I’ve replaced rhel5.iso by suse11.iso.

mount -o loop,ro suse11.iso /mnt01/tmp

Restarted nfsserver and exported /mnt01/tmp.
Ran vm-install and selected OpenSuse11 PVM
Disk image : phy:/dev/sdb8
Network URL : nfs://
Click “OK”.
Installer started fine, went through all phases successfully.
I just had to modify bootloader settings to place GRUB into
/dev/xvda. Usually this option gets selected by default.
Now, i have OpenSuse11 DomU running fine at OpenSuse11 Dom0.
So , vm-install does understand NFS share with loop mounted
opensuse11 iso image and doesn’t understand same share with loop
mounted rhel5 iso image. I would guess Xen 3.2.1 OpenSuse 11 Dom0 is missing some PV drivers to work with RH product.

I could test this tomorrow and see if I get the same results.
As far as drivers for an OS (in this case RedHat)… this does not come into play until later as far as I know.

To be sure I’m testing the same thing, might you have a download link for the iso you are using?


I purchased both (64 bit) DVDs CentOS 5.1 and OpenSuse 11 via the same Internet Shop.
DSL 30KB/sec is not good enough for 4.5 GB downloads.
Thank you.

Sorry, I meant the iso you are using for your guest, RedHat… just did a search but these iso’s cant be downloaded without an account as I understand?

Regarding CentOS distro a lot of testing has been done with Solaris xVM (b85-b93) as Dom0.
CentOS DomUs had been installed at SNV Dom0 via Solaris virt-install command line utility. Solaris NFS shares based on lofiadm’ed ISO images had been used as installation
sources per OpenSolaris standard instructions.

Thank you.

I used CentOS 5.1 ( free RHEL 5.1 clone).
It may be downloaded for free from any available mirror.

OpenSuse 10.3 PV DomU also installed at OpenSuse 11 Dom0.
I am pretty sure SLES 10 SP1 DomU won’t be a problem as well.
Looks like Xen enabled Suse’s Distros (DomUs) are supposed to be welcome. But nobody else.
Sorry , i’ve installed SNV_90 DomU via xen manager with no problems.


Any updates ?

Install CentOS 5.2 & F9 PV DomUs at OpenSuse 11 Dom0 via local HTTP Server (all 64-bit) « Xen Virtualization on Linux and Solaris