How to create a USB image

Ok, so it’s sdb;

umount /dev/sdb
winusb --format /home/raid/Win7.iso /dev/sdb
winusb --install /home/raid/Win7.iso /dev/sdb

I entered umount /dev/sdb and its says not mounted, then I entered winusb --format /home/raid/Win7.iso /dev/sdb and nothing happned,then I entered winusb --install /home/Raid/Win7.iso sda/sdb and nothing happened I am deeply sorry for my inompetence I am doing it wrong not you

No problems, unplug the device, plug it in and try again without unmounting… remember it’s /dev/sdb nothing else :wink:

bash: /dev/sdb: Permission denied… I also tried this as root/super user and I still get permission denied how do I fix this?

Ok, lets make a partition on it then;

fdisk /dev/sdb

If it doesn’t work, fire up YaST partitioner and use that to create a [type fat] partition on sdb.

Then probably unplug/plug the device back in, then check with lsblk, you should now see /dev/sdb1 so use that instead.

I created the new partition but i still get permission denied after typing /dev/sdb1

So it must be mounting read only, do you have another usb device to try?

Can you post the output from;

mount |grep sdb

I tried it here (it is slow… so be patient) and it is definitely /dev/sdb so no need for a partition…

new usb info from lsblk

If it doesn’t appear (as in your current output, then un-plug/plug the device back in. Then try the mount command.

I got some help from a friend I didn’t think he’s be available so soon. Thank you very much though the problem is now solved :slight_smile: