How to create a second programm shortcut.

I have LMMS 1.1.3 installed and alll works fine.

I also compiled LMMS 1.2 rc 2.5. This seems to work fine too but … I would like to have two shortcuts on my desktop.

One for 1.1.3 one for 1.2

What I have done so far.

Change kde to folder view and copied a second LMMS icon to the desktop.

Were I get stuck is at the commando I need to insert.

When I want to start 1.2 from the command line, I need to go to the build directory , and type ./ LMMS
this works fine but when I try to add this path and the command to the icon, it does not work.

This is what I added as command.
/home/guus/lmms-1.2.0-rc2/build ./lmms

Then KDEInit tells me it cant start lmms-1.2.0-rc2/build. :confused:

you need to create some (2) new desktop files (they’re regular text files)
see the content of
$HOME/.local/share/applications/
the above dir is where you put the new shortcuts (desktop files)
if you don’t have any user desktop files see system ones from
/usr/share/applications/
you can set the parameters of the application that you want to run
remember almost all apps in Linux are in your $PATH if your app is not you will have to use the full path to the app to run it
shortcuts appear on the menu bar if you want a shortcut on the desktop copy said desktop file to your desktop
$HOME/Desktop/

I have been looking at those folders, but I am getting more and more confused.

I found two short cuts from steam, those make sense to me.

One example the command for one of the games is:

steam steam://rungameid/41070

The LMMS shortcut though ( the version from packman) /usr/share/applications

has this command:

env QT_X11_NO_NATIVE_MENUBAR=1 lmms

I then tried copying the short cut from my desktop to the build directory.
If I click it, the normal version of lmms starts ( 1.1.3 )
So I changed the command to:

./lmms-1.2.0-rc2

Then I get the next error

 KDEInit kon './lmms-1.2.0-rc2' niet opstarten:
 Kon bibliotheek 'libkdeinit5_./lmms-1.2.0-rc2' niet openen.

 Cannot load library libkdeinit5_./lmms-1.2.0-rc2: (libkdeinit5_./lmms-1.2.0-rc2: kan gedeeld objectbestand niet openen: Bestand of map bestaat niet)

KDEinit cant start lmms-1.2.1-rc2
cant open lib libkdeinit5_./lmms-1.2.0-rc2
cant open shared something, no such file of folder.

are you using LMMS 1.1.3 from OSS
https://software.opensuse.org/package/lmms
anyhow this is the desktop file that comes with lmms
lmms.desktop

[Desktop Entry]
X-SuSE-translate=true
Name=LMMS
GenericName=music production suite
Comment=easy music production for everyone!
Icon=lmms
 Exec=env QT_X11_NO_NATIVE_MENUBAR=1 lmms
Terminal=false
Type=Application
Categories=Qt;AudioVideo;Audio;Midi;
MimeType=application/x-lmms-project;


you need to edit the Exec line to point to where you have the lmms executable something like

Exec=env QT_X11_NO_NATIVE_MENUBAR=1 /home/you/Documents/lmms-1.2-rc2/lmms

you can have 2 seperate desktop files for 2 different desktop files just remember to have different Name entries

Name=LMMS 1.1.3

and

 Name=LMMS 1.2-rc2

you should also edit the path to the LMMS icon so it displays in the menubar to something like

 Icon=/home/you/Documents/lmms-1.2-rc2/lmms.png

edit the path to where it is on your system and copy those 2 LMMS-1.1.3.desktop and LMMS-1.2-rc2.desktop to $HOME/.local/share/applications/ and you’re ready to go
you can use LMMS 1.1.3 from OSS and just build 1.2 rc2 and have 1 extra desktop file which you’d edit so it’s different from 1.1.3

The OP may find it easier to set them to run from the start button menu first. That allows the directory they run in to be specified if needed. That’s pretty easy to do - just right click on the button and choose the option. Icons that come with apps can be added here too.

Once they are there you can right click on them from the start menu and choose either add to desktop or add to taskbar.

I had something recently that for some reason had a desktop file that was flagged as illegal and that how I fixed it.

John

Thanks for the help, I got it working.

I have now two shortcuts on my desktop.
One starts the 1.1.3 from packman, nothing changed.
The one other starts the release candidate.

To sum it up.

I switched to folder view.
Copied the lmms icon from the desktop to the build folder of the release candidate.

Changed the command.

I used the search version to find what file starts LMMS. ( its not called lmms.so, just lmms.
I then went into the properties, of the lmms icon, and set the path to that file.

Then copied the shortcut back to the desktop and bingo

:slight_smile:

http://i.imgur.com/GWfbA9c.png

I forgot to add, I changed the name of the original shortcut from lmms to lmms 1.1.3 just to make sure it would not got over written when I copied the second shortcut back to the desktop,