How to copy OS from AHCI drive to Compatibility drive

Hi all,

New Thinkpad R61 with Suse 10 pre-installed. I want to re-configure to dual boot Suse 10 with Win2k on a new SATA HD (and I’ll leave the original HD alone for now). Since I’m new to Suse, I’d like to just port the existing pre-installed OS to the new HD, rather and re-install. But I’ve run into a snag…

I partitioned the new HD and ported the Suse install with ‘dd’, then installed grub, modified /etc/fstab and all worked. Win2k Pro does not support AHCI, so I had to set the BIOS to Compatibility mode, and installed Win2k. That works. But now in Compatibility mode, I can’t boot into Suse anymore (…if I switch back to AHCI, Suse works, but Win2k does not). Plus, I noticed in Compatibility mode that some upper partitions are corrupt (oddities in fdisk -l), so I’d like to re-partition just that upper part of the HD with the BIOS in Compatibility mode, and port the Suse install from the original HD over to the new HD again.

The problem is that since the HD is in Compatibility mode now, I’m pretty sure ‘dd’ won’t work to copy a partition that was created in AHCI mode to one that’s setup as Compatibility mode. Obviously there are differences with the way this data is saved on the HD, right? (I have not yet been able to find any good info explaining the differences between these modes). Or is my assumption incorrect? Is there another way to port the install, or am I forced to download and re-install from scratch? I’m really not sure how to install drivers in Linux. FWIW, the original HD would be in an external USB drive enclosure, but it seems the AHCI/Compatibility BIOS setting affects that too.


I too have a R61 as in sig. But it came with Vista and is now running open SuSe 11. Vista is still there but I just don’t use it. I can tell you I had to figure my way around this setting in BIOS too.

To explain briefly: At first (remember the BIOS is AHCI) I decided to just install suse with Vista. Fine. But Vista was so slow, I decided to install XP. For me the easiest solution was to wipe the disk. But of course XP couldn’t handle AHCI so I switch to Compatibility. OK. Now I have XP and OS11

I was just never using XP and you know how it is. I decided I wanted Vista back, mostly because people keep ringing me up asking for Vista help - so I needed to be able to see a Vista desktop.

So now Vista and OS11 are both installed with BIOS in Compatibility mode.

As for you problem, I’m not sure. Have you considered Clonezilla. Might that do better than dd

Assuming you mean SLED, why not just download the SP2 DVD and use that
to install from? Have you tried adding to the options at the grub boot

Plus these are the openSUSE forums, the SLED forum is at which may glean some extra results :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 12:05, 1 user, load average: 0.08, 0.17, 0.22
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

caf – Lenovo has drivers to use XP with AHCI. See here…
No, I haven’t looked into aftermarket cloners.

Malcolm, yes I think it is SLED. I never knew about that acpi=off option. Think I’ll try that next. I really want to avoid a fresh install from the DVD because I expect a bunch of complicated questions and driver installs and I’m new to Suse. (…painful memories of lib conflicts with RH7, Slack 9, etc when I was into Linux some years ago).


I use SLED but on a desktop (and hang out in the SLED forum) . It’s
based around openSUSE 10.1 but it I don’t think there should be any
issues. Have a browse/search at the SLED forum also check what patch
level your at by running the commands;


cat /etc/SuSE-release

If you not at patch level 2, I recommend the download.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 12:47, 1 user, load average: 0.27, 0.17, 0.19
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82