How to connect wired, and configured pppoe network from terminal?

Ok, so I have messed up my gpu driver on laptop, and trying to fix it. I have an NVIDIA optimus laptop with an Intel vga, and a 720m dedicated card. I installed the 550 propriatory driver, but haven’t configured bumblebee, nor Nvidia prime yet.

MMy first question: is there working Nvidia prime, on openSUSE, and if there is, how to intall it?
The second is ofcourse the title of the thread.
I had a small problem with wicked, after a cean install, but was able to configure DSL connection, now, from terminal I don’t know how to access it.
This is my first time on the forum, second time I try openSUSE. Thanks for the help i advance!

I know that ‘pppoe-setup’ can be used to configure a working connection, (although I’ve never needed to use it). Have you tried using ‘pppoe-start’? Other than that, I can only suggest reading the man pages for the pppoe-* CLI utilities.

This may well be relevant to you as well:

First remove any normal NVIDIA driver you may have installed completely.

Second you must install bumblebee first then install only nvidia-bumblebee package NOT the normal nvidia package

Instructions her but remove the regular driver first

Thanks for the fast, and helpful reply!
Well I configured the pppoe in terminal, but it didn’t worked, after that I tried to tweak the config file, with no success.
Strangely when I uninstalled the NVIDIA proprietary driver, and did a reboot X started up. That’s strange, because I blacklisted nouveaou driver, and uninstalled it.
So I don’t know what sort of sorcery is this. Is mesa running my GPU now?
I will try the bumblebee now, and if you now anything about Nvidia PRIME on openSUSE…
Sorry for my bad English.

Oh, and of course my network problem solved, because of the appearance of X an GNOME.

So, you have pppoe running now?

There are other drivers beside nouveau so it is one of the fall back that is being used if you blacklisted nouveau. BTW there is absolutely no need to remove the nouveau package the driver itself is actually built into the kernel

Optimus is a special hardware configuration and you simply can not use the normal drivers in Linux. NVIDIA does not truly support there brain child on Linux. And the normal driver modify the mesa files and make them unusable by other GPU flavours. SO you have to use the special bumblebee version.

Yes, but I configured it in GNOME with nm-connection-editor because the default manager ‘wicked’ can’t create pppoe connections.
I tried pppoe from terminal, but without success. Maybe I could do it with rp-pppoe, but I haven’t tried it, because it solved itself, when graphic interface showed up.

It’t possible, that in the afternoon I will give it a shot.

If NM is working for you, I’d stay with that. The CLI utilities I mentioned are part of ‘rp-pppoe’. The thread I linked to back in post #3 is worth reading,