how to connect vino's remote desktop to the current session?


my OS is SuSE 11.2 with gnome.
Remote administration is active.
The VNC-session then connects to the login-screen and after login opens a new desktop.

How can vino be configured to attach to the desktop that is already running. (Ubuntu does that per default so it should be possible with SuSE too:))

THX, stn

Have you checked the Remote Desktop Preferences in Control Center?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 10:59, 3 users, load average: 0.24, 0.18, 0.17
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

All right, thank you. There it is.

I activated ‘remote administration’ in yast (with no option of logging on to the current desktop)

What I was looking for was ‘remote desktop’ in the control-center.

2 different remote modes. OK, got it now :slight_smile:

So now I have 3 open vnc-ports:

tcp        0      0*               LISTEN      0          9123734    8594/qemu-dm
tcp        0      0  *               LISTEN      0          16223      3021/xinetd
tcp        0      0 :::5902                 :::*                    LISTEN      1000       12257312   25525/vino-server

Presumably 5902 leads to the new ‘remote desktop’.
Does 5900 belong to xen ? :confused: And 5901 to ‘remote administration’ :confused::confused:

That should clear up soon. What I really want to know is this:

Is there a way to change the ports (all of them?) to something completely different? That helps keep hackers away :stuck_out_tongue:

TIA stn

I would turn off the one you activated via YaST.

You can modify the port via the control center settings, but in YaST ->
Firewall -> allowed services you need to add the ports your wanting to
use via the ‘Advance’ button.

Unless your router can handle port forwarding so you could configure
that to just accept on xxxx and forward to xxxx

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 3 (i586) Kernel 2.6.33-5-desktop
up 14:08, 2 users, load average: 0.08, 0.04, 0.01
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

No, exactly that does not work. At least not in the same control-center-tab that activates ‘remote desktop’. Or is it somewhere else?

Some versions ago there was the option of changing the vino-port, at least for ubuntu. One version later it was gone again :frowning:

I checked what the several open vnc-ports are for:
5900 is a virtual machine (xen)
5901 is ‘remote administration’
5902 AND 5903 are opened by vino. 5903 works and show the current desktop (as wanted), 5902 shows only a white screen.

So it would really be helpful if it were possible to put vino on another port. Otherwise the port would be different depending on whether the VM is active or inactive during gnome-start.

(The VM also runs gnome, same as the host, so its vino-port can only be changed if the host’s vino-port can be changed. Kind of recursive :))

TIA, stn

Use gconf-editor and it’s under
Desktop->Gnome->Applications->remote_access here you can change the

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 3 (i586) Kernel 2.6.33-5-desktop
up 0:34, 2 users, load average: 0.29, 0.20, 0.12
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Found it! Malcolm, thanks.