How to connect to nas network drive?

on ubuntu and windows I use this ip to connect to a nas network windows workgroup smb://
on opensuse KDE I have tried from dolphin’s network all options but none work so how?

You started and configured Samba? I ask because you do not say you did anything like that. Look here for a good tutorial: openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

Samba is probably already running on the NAS, if by that he means an off the shelf box. OP you have to be more detailed about what you did or did not do. I have no problem connecting to SMB shares from KDE.

thanks for the reply
do I need to install and configure samba for this? I’m not planning to run a samba server or share files from this computer but just browse the network nas drive, smbclient is just the tool for this and I checked it’s installed so how does it work in opensuse? it should be simple! also I don’t want to system mount the drive only use a local mount for the drive when the computer is connected to wired network, I use wireless sometimes and the drive is not on the wireless network.

what about posting the output of

/sbin/ifconfig -a

My guess is that you’re not in the same lan as your NAS.

did you have to open any firewall port?
or how do you connect to the off the shelf box? what option did you choose in the dolphin network, I tried with the network folder but it refused the connection.

output of /sbin/ifconfig -a

eth0 Link encap:Ethernet HWaddr BC:AE:C5:B7:01:7F
inet addr: Bcast: Mask:
inet6 addr: fe80::beae:c5ff:feb7:17f/64 Scope:Link
RX packets:907 errors:0 dropped:0 overruns:0 frame:0
TX packets:1015 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:422761 (412.8 Kb) TX bytes:267270 (261.0 Kb)
Interrupt:41 Base address:0xe000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:154 errors:0 dropped:0 overruns:0 frame:0
TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:14297 (13.9 Kb) TX bytes:14297 (13.9 Kb)

No. You don’t. As far as I know, you could also connect to a samba server from a live CD. Maybe you should try that first.

No, since openSUSE is the client, generally there are no firewall restrictions on connecting out. I just clicked on the network icon and browsed to the share I wanted. You should check if there is any setting on the NAS to allow only certain clients. And follow any advice others give to check if you on the same subnet as the NAS. BTW, I’m on openSUSE 11.3. You didn’t say what release you are on, another piece of information that should not have to be wheedled out of you.

Are you sure about your NAS ip ( ? It looks like a router ip. What is the output of:

/sbin/route -n

I’m on opensuse 11.4
I just tried connecting with ftp (from the same dolphins add network folder option) and looked like it was going to work, it even asked for the nas drive user password but failed the connection (ftp on firefox works okay).

I just clicked on the network icon and browsed to the share I wanted

if I do that I just get a blank window

it is the router ip, its a router with built-in nas server

Destination Gateway Genmask Flags Metric Ref Use Iface U 1 0 0 eth0 UG 0 0 0 eth0

Short remark to @gandaran. Please, next time you copy/paste computer text in your post, do so between CODE tags, not QUOTE tags (Posting in Code Tags - A Guide). It will make the mass of numbers much more readable.

Like this one:

henk@boven:~> /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   U     0      0        0 eth0     U     0      0        0 eth0       U     0      0        0 lo         UG    0      0        0 eth0

See the difference(s)?

okay, thanks

anyway I tried a second time with the ftp option and it did connect this time, I have a nice nas folder now in the file browser with all the drive files except one private folder that is only shared via samba so I would still like to have the smb connection instead.

after trying everything including enabling samba client in the firewall and googleling the subject (found many posts with same problem on opensuse 11 but no fix) there was in fact a simple way and probably the only way to connect a samba share easily in opensuse 11.4 KDE that I overlooked, all I had to do is type the IP in the dolphin file browser url bar!!!