How to Connect to a USB Printer on a network?

Hello:

I’m trying to connect to a USB Printer on a shared network. The Printer is connected to another computer (Computer-B) via USB port. And my computer (Computer-A) shares the network (ethernet connection) with other computer (Computer-B).
Computer-A has dual OS: Windows 7 and openSUSE. The printer is configured on Windows 7 and prints well from there. But I’m having difficulty configuring the printer on openSUSE. I tried searching for the printer, but can’t find it as it’s not the network printer. It’s connected to the other computer via USB port. The other computer (Computer-B) has runs a Windows XP OS.
The printer model is: HP LaserJet P2015d Series PCL 5e

Does anybody have an idea on how to fix this problem?

Thanks.

On 2012-08-22 22:56, ap1985 wrote:

> Does anybody have an idea on how to fix this problem?

I’m a bit confused as to which computer has what.

Assuming the server computer has openSUSE and is connected to a printer via usb, you just have
to configure cups to listen and serve on the network. The configuration file is commented and
cups has help with a browser on port 631.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

The server computer has Win XP and is connected to the printer via usb. My computer has openSUSE and I’m trying to configure the printer on it.

On 2012-08-23 00:06, ap1985 wrote:
>
> The server computer has Win XP and is connected to the printer via usb.
> My computer has openSUSE and I’m trying to configure the printer on it.

Then you have to share the printer in Windows, then import it with Samba in Linux. I’m not very
familiar with the procedure.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

The printer is already shared in Windows on the server computer. I’ll have to check the Samba settings in openSUSE on my computer. Thanks robin_listas.

P.S. As I said earlier, if I boot my computer with Windows 7, the printer is already configured and works fine. I just don’t know how to configure on openSUSE.

On 2012-08-23 02:56, ap1985 wrote:
>
> The printer is already shared in Windows on the server computer. I’ll
> have to check the Samba settings in openSUSE on my computer. Thanks
> robin_listas.
>
> P.S. As I said earlier, if I boot my computer with Windows 7, the
> printer is already configured and works fine. I just don’t know how to
> configure on openSUSE.

I just had a look. Fire up yast, hardware section, printer. There select print via network,
then the wizard. In the wizard there is a section for use windows print server, try it.

I can not because I don’t have a Windows machine with printer.

Alternatively I see that the cups local web page (you know it, I hope?) has an item for samba
printers in the add printer section.

You just have to look :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Good News: I found the usb printer on the network… I was able to add the printer after I entered the server computer’s login info in Samba.

Bad News: I’m getting an error message. I think it has something to do with the Cups settings and I don’t know how to configure that yet. I’m still looking for the resources on the website and forums, but no luck yet! :frowning:
Here is the screenshot of the error that I’m getting…

P.S. It says to click the ‘Enabled’ checkbox, but I don’t find any “Enabled” check box when I go in the “Policies” under the printer in printer admin tool…

http://i48.tinypic.com/dpz335.png

DONE!!! <breathing a sigh of relief> :slight_smile:

I can now finally print from my openSUSE to the usb printer attached to Windows XP server.

I was able to find the “Enable” option under the printer properties > Policy

Thanks @robin_listas for taking time to read and reply this thread!

On 2012-08-23 20:06, ap1985 wrote:

> Thanks @robin_listas for taking time to read and reply this thread!

Welcome.

And thanks to you if others come with the same problems they can read it here :slight_smile:

I had no idea of that enable option.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)