How to connect 3g gsm data card to internet in opensuse 11.3(Gnome)

Hello Friends,

I recently purchased a Micromax 3g GSM usb data card(MMX 352G). I am using it in windows 7 but now I want it to connect to the Opensuse 11.3 to use internet.

This modem is not detected by the command “wvdialconf”

the device is detected by command “lsusb” as 1c9e:9605

I don’t know what to do next.
Please Help!!!

Is the modem in the machine when you turn it on?
And does rfkill think the interface is blocked?

I started the computer with and without the device in it but no device is detected.
I don’t know rfkill is a command or not. If it is then it is not running in the terminal.
It shows ‘rfkill’ is not a typo…".

Even opensuse doesn’t detect the CD created by the modem containing the the modem drivers for Windows and Mac.

I googled this problem and I found some articles about my problem and worked accordingly and created a script in /usr/bin folder with the contents:

sleep 5
usb_modeswitch -W -c /etc/usb_modeswitch.d/1c9e:f000
modprobe usbserial vendor=0x1c9e product=0x9605

This script makes my device to be able to detected by wvdialconf as /dev/ttyUSB1

I previously used wvdial with my mobile phone. So I configured it to work with my DATA CARD. but nothing worked.

I also tried Kppp. I configured the modem in kppp and is querying superbly, but still not able to connect to the internet.

Then I tried UMTSMON which also detects my device after running the above script.
It shows the signal strength indicate the presence of UMTS signal but when I try to connect the Internet it shows a progress bar to 100% and after that it shows Disconnecting in place of signal indicator.
Same is the problem with Network Manager.

Please help.

I’m glad you found out about the usb_modeswitch.
Can you post the output of wvdial?
rfkill must be installed via zypper.

zypper in rfkill

But you already figured out that isn’t the problem.
Does openSuse detect any CDs?