How to configure VNC to act like in SLES?


I’ve got 3 quite big data servers running SLES 10. I’ve recently been asked to build a simple computer that would share a 1 TB drive that would serve as a TEMP share (where ppl could save their various stuff). Anyway, I’ve decided to install OpenSUSE 11.2 on that computer since buying SLES for it would make no sense.
Samba and FTP configuration went smoothly, but I’m having problems configuring VNC. Since I have SLES on 3 other machines I’d like the OpenSUSE machine to act the same way, so basically I just need to enter the machine IP followed by screen number (:1 is only active by default) to connect to the logon screen where I can login as any user and get access to full gnome desktop (all in 1024x768 resolution). Any hints?

Seems I found myself a solution, sorry to have bothered all of you:
one has to edit /etc/xinetd.d/vnc configuration file and delete or comment (or change to no) the line disable = no in the entry configuring the first screen.
Also another configuration file has to be changed (/etc/sysconfig/displaymanager) to get rid of the “no foreign root login allowed” error, the entry that needs to be changed is:

Ok, I’m replying myself again, since not everything is working as it should, for example I can’t run YaST when I’m logged in remotely. I’m out of ideas…

This method works for me in 11.2: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

Thanks swerdna. I’ve actually already have visited this link, when I was googling for some answers regarding my problem. Your method is fine but it’s not what I’m after.

Anwyway, I’ve managed to track the problem that was causing YaST no to run. The command that is used to run YaST from the GUI is “/usr/bin/xdg -su -c /sbin/yast2”, when you run it from the console, you’ll see an error saying something like “Invalid MIT-MAGIC-COOKIE-1 key Can’t open display”. Apparently this error can be solved by adding the localhost to the access control list by typing “xhost +localhost”. Now everything works fine.

Glad it’s working for you now.

For me YastGUI can be launched remotely OOB (so to speak) using the icon in the general menu, or either of these terminal commands

su root -c yast2

su -c yast2

No tweaks required – strange.