How to configure USB soundcard?

I have been trying for a while now to configure my Edirol UA-1EX soundcard on Leap 42.2.
I have installed alsa-firmware, alsa-plugins-* alsa-utils. The only suitable-ish sound card module that show up in yast is snd-ua101, which gives the soundcard options UA-1000 and UA-101. I’ve tried both of these and both fail when configuring with ‘The kernel module snd-ua101 could not be loaded’.

I’ve tried alsaconf, but it fails to detect any soundcards at all and just exits.

lsusb shows:

spoovy@thinkpad:~> lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. BCM2045B (BDC-2.1)
Bus 001 Device 003: ID 0582:0096 Roland Corp. EDIROL UA-1EX

This card works out of the box in other distros, so I have no idea why it seems to be such a battle with openSUSE. Any advice on how to proceed greatly appreciated.

Thanks in advance.

The last t ime I configured an USB connected sound card was in openSUSE 13.1. I did then same as in earlier openSUSE releases. I do not knnow if that has changes. Also, because that is some time ago I am not sure of all the details.

YaST > Hardware > Sound.
Then the Add buton. On the new screen the left column has Generic. Then the right column has only one item USB Audio. Etc.

IMHO you can then use the device in tools and programs.

Brilliant, thank you, that sorted it. \o/
I have to do a bit of a dance with the pulseaudio control to get it to use the new device but that’s OK.

You are welcome.

It is one of those things that look very logical after you found out. lol!