How to configure panels in KDE 4.1??

Hi all,

I’ve just installed OpenSUSE 11.1 and made the leap from KDE3 to KDE4. I was doing really well and happy with things and then I made a huge mistake and started tinkering with the system panel. I have to say, the interface for making changes to panels is VERY confusing. It’s hard to pick up some widgets without doing things you didn’t intend. For example, the system tray has the little cross on it to move it but you can’t help but accidentally start sending commands to the programs sitting in it. Why did they turn off the application interaction while you’re making changes to the panel??

The real reason I’m posting here, though, is that somehow the system tray has become MASSIVE. It takes up almost the entire panel and I can’t figure out how to make it smaller. There are no resizing ‘edges’ to it and I just don’t know how to make it smaller. I really need help because my system panel is now completely messed up and I don’t know how to put it right. I tried creating a new panel and recreating the system panel but I fell over at the first hurdle because I couldn’t find a ‘Start button’ in the widgets. D’oh!

Any help is really appreciated! :o)

Okay, so I’ve been playing some more and I managed to recreate the system panel at the top of the screen and I was about to start trying to swap out the old one that was messed up but did a reset (a log off would probably have worked) first. When I get back into KDE the bottom panel had sorted itself out into something slightly more sensible and I was able to shuffle the widgets about to put it back the way it was before I started messing with it.

I guess I would have to say that the interface for changing panels is a bit buggy and really needs looking at because it shouldn’t be possible to get into the mess I managed to get into. Why the system tray became insanely huge is anyone’s guess and it completely destroyed any chance I had of putting it right. It’s just lucky that I reset the machine before I went any further and it sorted itself out! A more novice user would have been totally baffled about what was going on.

Yes have had this too it’s a bit better in 4.2 beta2 which is a lot better all round IMHO
though would not recommend it for new users as it requires fixing a few dependencies
to get it working.
When the final version is out it will be RnR (hopefully) :stuck_out_tongue: