How to configure network settings during installation

Hi guys, I’m new here. Done loads of research on how to install Leap 42.3 properly, but the one thing I haven’t been able to figure out is how to get my wireless up and running during install so I can add the online repositories. Plz help me.


Personally, I exclusively use an Ethernet cable on machines where openSUSE is either being installed or upgraded.
Having said that, the openSUSE Installer does allow a WLAN interface to be used and, for that case, it offers the possibility to enter the WLAN access keys.
[HR][/HR]But, it may very well be that, your WLAN hardware will require Firmware which is not included in the openSUSE Installer.
Therefore, in this case, you will have to use an Ethernet cable to perform the installation or upgrade (assuming that, the upgrade is being performed by booting a DVD image) because, the Firmware required for your WLAN hardware will have to be downloaded.

I’ve installed leap and it seems to be running fine. I’ve got an ethernet cable in but I’m still not getting any internet connection. What am I missing here?

Assuming a default installation and a Laptop with WLAN, the network is controlled by “Network Manager”, and not by “wicked”.

With YaST (use a “normal” user – it’ll ask for the ‘root’ user’s password) go to “Network Settings”, the “Global Options” tab and check which network management method has been selected.
As a “quick and dirty” solution, select “wicked” and then go to the “Overview” tab and setup the Ethernet interface to use DHCP to setup and establish a connection to your Router.

Once again, assuming a Laptop. once the Ethernet is up and running, with YaST and “Network Settings” – “Global Options” – reactivate the “Network Manager” and then setup your WLAN keys via the user’s GUI.

As a KDE user, I’ve absolutely no idea what the GNOME world does – be aware that, KDE uses a Wallet for the encrypted storage of WLAN keys and other passwords – with KDE you have to setup the “KWallet” before you can setup the WLAN keys – please see the openSUSE documentation for details: <>

You check from bottom to top:

  1. Is the NIC up with an IP address?
ip addr
  1. Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  1. Do you have a default route to the Internet?
ip route
  1. Can you connect to a system on the internet?
ping -c1
  1. Can you resolve host/domain names?
ping -c1

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

david@linux-p9vc:~> ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether f8:a9:63:4b:1e:53 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 28:b2:bd:c8:44:39 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic wlan0
       valid_lft 1312sec preferred_lft 1312sec
    inet6 fe80::2ab2:bdff:fec8:4439/64 scope link 
       valid_lft forever preferred_lft forever
david@linux-p9vc:~> ip route
default via dev wlan0  proto static  metric 600 via dev wlan0  proto dhcp  metric 600 dev wlan0  proto kernel  scope link  src  metric 600 dev wlan0  proto static  scope link  metric 600 
david@linux-p9vc:~> ping -cl
ping: bad number of packets to transmit.
david@linux-p9vc:~> ping -cl
ping: bad number of packets to transmit.

I’m at my university, so I don’t know the IP address of my router.

dcurtisfra’s quick and dirty method seems to have worked, though I can’t set up these keys he mentioned because the Kwallet isn’t working.

  1. You have wlan0 up and running with IP address
  2. You can of course ping any system in your LAN to prove that you have correct access to your LAN. But 3. shows that your default router is
  3. You have a default router, thus that must send your packages to the Internet.
  4. You did not copy/paste what I suggested and thus you have made a typo. It is NOT
ping -cl

, but

ping -c1


  1. Same as 4.

For the life of me I can’t see the typo, but it worked this time

david@linux-p9vc:~> ping -c1                                                                                                                                                                                                                                       
PING ( 56(84) bytes of data.                                                                                                                                                                                                                           
--- ping statistics ---                                                                                                                                                                                                                                            
1 packets transmitted, 0 received, 100% packet loss, time 0ms                                                                                                                                                                                                                  
david@linux-p9vc:~> ping -c1                                                                                                                                                                                                                               
PING ( 56(84) bytes of data.                                                                                                                                                                                                                   
--- ping statistics ---                                                                                                                                                                                                                                    
1 packets transmitted, 0 received, 100% packet loss, time 0ms

Wow I see the typo now. it was the number 1 not the letter l. They literally look the same.

I understand that you can not easily copy/paste from my post without internet access ;),
but yes, a 1 (the number) is not an l (lower case Lima)is not an I (upper case India). Depends a bit on the font how different they look.

But the first ping already shows you can not connect to outside your LAN.

BTW, did you try inside the LAN

ping -c1

That should be your gateway to outside according to your routing table. And when you can not reach it, you can not go outside of course.

I must admit that I only answered to your last question: I am still not getting any internet connection. And I answered with the standard way of trying to debug such a case. From inside the system (NIC) step by step until stuck. And after that of course try to find out why that step is not functioning correct.

I now read earlier posts here. Can you please show the results of the configuration you creatted using YaST by showing:

cat /etc/sysconfig/network/ifcfg-wlan0

Take care! there might be a WPA password in there, make ******* out of it before posting.

BTW, when you use wicked, the password is in this file. It is not managed by Kwallet. That is only done when the NIC is managed by the user through NetworkManager.

Pinging inside LAN:

david@linux-p9vc:~> ping -c1
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=255 time=1.91 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.910/1.910/1.910/0.000 ms

I get permission denied when I try to get the YaST config:

david@linux-p9vc:~> cat /etc/sysconfig/network/ifcfg-wlan0
cat: /etc/sysconfig/network/ifcfg-wlan0: Permission denied

The ping shows that you connect to the LAN and that the other one is alive and kicking :wink:

Hm, strange. I can cat these files as normal user. Please try as root

su -c 'cat /etc/sysconfig/network/ifcfg-wlan0'

That worked:

david@linux-p9vc:~> su -c 'cat /etc/sysconfig/network/ifcfg-wlan0'
NAME='Wireless 7260'

As far as I can see, that looks good. It uses DHCP and the DHCP server should set the IP address, umask (which it did correct, because you can live in the LAN) and the default route (which looks fine to me and which you can reach with ping, thus it is at least a living system).

I have no idea why you can not ping through it to the IP address of the forums .
Something you could try is

su -c 'traceroute'

Then you can see where it stops.

I can use the internet on my laptop now. Posting from it. Here’s the trace:

david@linux-p9vc:~> su -c 'traceroute'
traceroute to (, 30 hops max, 60 byte packets
 1 (  2.375 ms  2.768 ms  2.894 ms
 2 (  38.372 ms  40.188 ms  40.167 ms
 3 (  7.312 ms (  6.164 ms  7.296 ms
 4 (  7.283 ms (  7.911 ms  7.904 ms
 5 (  7.902 ms (  11.948 ms  12.437 ms
 6 (  12.450 ms (  5.764 ms  8.768 ms
 7 (  10.863 ms  10.874 ms  10.860 ms
 8 (  20.940 ms  22.402 ms  22.381 ms
 9 (  35.863 ms bx2-montreal01_tengige0-1-0-4 (  22.389 ms (  37.361 ms
10 (  34.377 ms (  37.356 ms (  37.053 ms
11 (  32.389 ms (  31.826 ms (  35.465 ms
12 (  33.021 ms  31.255 ms  32.069 ms
13 (  30.406 ms (  32.014 ms (  28.569 ms
14 (  44.769 ms (  30.365 ms  30.379 ms
15 (  50.309 ms (  50.295 ms  48.501 ms
16 (  58.233 ms (  49.072 ms (  56.850 ms
17 (  46.177 ms (  49.069 ms (  47.436 ms
18 (  47.363 ms  45.746 ms  47.336 ms
19 (  48.723 ms  48.732 ms (  102.112 ms
20 (  103.957 ms  103.966 ms (  103.963 ms
21 (  103.952 ms  103.601 ms  102.067 ms
22 (  103.580 ms  103.577 ms  103.563 ms

Every time I try to connect to a network, a dialog pops up saying to set up Kwallet, then gives me a blank window saying to select an encryption key from an empty list… so I’m stumped on that

That ping works now. Don’t know why, but it does.

david@linux-p9vc:~> ping -c1
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=49 time=102 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms                                                                                                                                                                                                                    
rtt min/avg/max/mdev = 102.449/102.449/102.449/0.000 ms

So all I need to do is figure out this Kwallet thing then I should be good to go move on to the next round of post-install setup.

Nice you have connection. Not so nice we do not know why this spontanious happened :wink:

If I want a network settings screen during install, I unplug the ethernet cable before I boot the install media. That way, a network settings screen shows up.

Whether this helps, will depend on whether there is a driver for your WiFi card. If your card requires a driver that is not open source, then you still won’t be able to get wifi working until you add the driver after the install.

And at that point I always connect the ethernet cable again because after providing the parameters, there comes a screen that asks you if you want to test the connection. And without a connection that testing will go wrong.

Yes, it is a silly way of doing an installation. Specially frustrating when you realize that earlier there was one simple box “Automatic Configuration” to uncheck to give you the reins.>:)

Assuming that, the GUI you’re using is KDE, open the System Settings, in the “Personal Information” select “User Account details” and then “KDE Password wallet”.

  • Create a new wallet with the name “kdewallet” – the default wallet name . . .
  • As a first time user, choose the Blowfish encryption and, to keep things (initially) simple, use an empty password – really . . .

Yes, yes, there are ways to setup with a password but, the further setup to avoid having to enter the password at every login needs a considerable amount of reading in the KDE (and ArchLinux) documentation . . .

Using GPG encryption needs somewhat more effort and, AFAIK, there’s no way to avoid having to enter the wallet’s password at each login and during a login session whenever the wallet needs to be used . . .