How to configure Java in KDE, Firefox crashes.

I have OpenSuse 11 installed on my Desktop x86. Everything works pretty good so far, but Java.
Seems like Java gets installed automatically upon istallation the system. Jave check says I have everything installed. But when I try to access java enabled platform (stock trading system) it fails and the Firifox just stalles. I am not sure but I guess its KDE issue. Couse I have the same problem on my laptop x64 where I installed Pardus. What seems to be the problem? Do I need a firefox plug-in or smth. to get it working. I did flush plug-ins and one time the apllete worked fine. Dont now how it happened. Since then - no luck. It tries to run the applet but after a while Firefox just freezes.
Previously I used Gnome Ubuntu and it worked perfect. Thats why I assumed it is a KDE issue, not OpenSUSE in particular.

Have you installed the Java Virtual Machine using YaST?

I don’t see Java Virtual Machine in Yast. I have Java runtime and Java plugin installed. I tried to install GTK Java but it didnt help either. Its strange that generally Java works. It only does not work with my trading applet for some reason. :cool:

Try JVM not Java Virtual Machine

What flavor are you running 32 or 64

The Quick Java Switch and Fix