How to configure a DNS server by YAST2

I run these commands to install DNS server dependencies on openSUSE Tumbleweed:

sudo zypper in -t pattern dhcp_dns_server
sudo systemctl enable named.service
sudo systemctl start named.service

To configure the DNS server, I’m trying YAST2 following this documentation:

https://doc.opensuse.org/documentation/leap/reference/html/book-opensuse-reference/cha-dns.html:slight_smile:

sudo yast2 dns-server

I intend to configure example.com domain zone with IP address 1.2.3.4.

What I did

I have a DNS zone of master type:

https://i.stack.imgur.com/sNF78.png

My NS Records tab is:

https://i.stack.imgur.com/fivUs.png

My Records tab is:

https://i.stack.imgur.com/fvEWZ.png

Problem

However, saving the configuration runs into a problem:

Warning

Saving the configuration failed. Change the settings?

https://i.stack.imgur.com/zPRpL.png

I couldn’t figure it out. Can anyone help?

Also

I ran these commands and reconfigured the DNS server. But the observation is the same as before:

sudo systemctl revert named.service
sudo rpm  -qV bind
sudo cp /etc/named.conf.YaST-backup /etc/named.conf
sudo yast2 dns-server

The save problem of:

> Warning
>
> Saving the configuration failed. Change the settings?

Got resolved by stopping the named service before launching YAST:

sudo systemctl stop named.service

Good that you were solving the issue yourself by stopping named.service

If you want this to be fixed for the future and for others I recommend you to create an issue at Bugzilla, chose as Component Yast2.

It looks like you are trying to use and for fixed font/code but that does not work for this forum, you can select the font and use CODE tags using the hash button. Switching the editor to Source mode (top-left button) and Preview Post can be helpfull.

Thanks! It’s reported here: 1186046 – Have to stop named service before launching YAST2 to configure DNS server