How to compile source code

Hey All.

I made the switch from Windows to Linux the other week. It’s been pretty good. OpenSuse has pretty much every program I want, or available to install. But I sometimes see some only available in source code, so I’d like to know how to compile and install it.

I found this page Compiling software - openSUSE about it. But I got stuck at the part where it says

“First you need to install the development tools. In YaST, go to Software Management, then filter on Selections. Choose at least C/C++ Compiler and Tools. You might also need KDE, Gnome and Tcl/Tk Development and in some cases Kernel Development. The only drawback of installing all this together is a loss of disk space.”

I opened up Software Management and typed in C++ and tons of things to install popped up. I have no clue what compiler(s) to install, which is the best, etc. If someone can tell me exactly which ones I should install, that would be great.


EDIT: I’m using GNOME is that makes any difference.

at a minimum, installing kernel-sources, gcc/gcc++ & make will see you through a compile. adding gnome-devel will help in some gnome compiles


On openSUSE 11.0, I choose filter on ‘Patterns’, scroll down to the checkbox ‘Base Development’
and check that. (It’ll bring in tons of stuff.) Do ‘accept’ and let it all install.

My 2-cents worth…


I would agree with deltaflyer44. At minimum you should need:

  • kernel-source
  • gcc (I use gcc43)
  • gcc-c++ (I use gcc43-c++)
  • make

Then I would also suggest these because every once in a while they pop up:

  • automake
  • flex
  • bison

After these are installed, you should be good to handle a majority of the stuff out there. Everyonce in a while, something might need something, but it should alert you near the bottom of the output what it is needing.

Thanks for the replies. So I think I’ve installed those things you listed antiparadigm.

(cookdav I searched patterns and couldn’t see base development, maybe I don’t have the repository?)

Anyway, I guess I’m not doing it right, or I don’t have everything I need installed. I’m trying to compile/install the linux poweriso program. (PowerISO - Create, Edit, Extract, Mount, Compress, Encrypt, Split ISO file, ISO/BIN converter, Virtual Drive, DAA)

It’s untarred. And I open up the terminal in gnome and type ./configure and I get “bash: ./configure: No such file or directory”
I type cd and the directory of where the package is, and then ./configure and I get the same error.
I type ./configure poweriso and I get the same error.

Can someone please help?


In the list of files in the PowerISO directory there should be some text files such as README and INSTALL with instructions for installing the package.