How to choose theme for Yast?


Using OpenSuse 11.2 RC2. After playing around to install the nvidia driver, Yast lost its beautiful initial colours (light blue, as the rest of the kde desktop) and became a bit uglier (dark blue, more rudimentary, etc; I think the default “unbranded KDE”'s colour).

I have the KDE theme set either for the regular user and for root. I have also installed the packages yast2-theme-openSUSE and yast2-theme-openSUSE-Oxygen installed but, how shall I choose one of them?

Some webs say that there is an option in Yast under “miscellaneous” to choose Yast’s theme, but I do not have it.

Thank you very much in advance.

The standard answer I think is run ‘qtconfig’ from a root console, but if you’ve already set root’s theme I don’t see how it will help. Try anyway, maybe…

Wow, it worked. You run qtconfig as root, and on “select GUI style” you put “Desktop Settings (Default)”. It may be already selected, then you have to select another one, save, and then select “Desktop Settings (Default)” again.

Thank you.


That was lucky… :slight_smile:

I had the same issue, and that fix worked for me, thanks ! (after applying other theme, then default theme and a logout/login)

It worked for me too. Somehow the appearence of YaST changed to Plastique, now it’s back to Oxygen. Thanks!