how to check if i run the newest version of digiKam ( under kde )

i run opensuse version 13.1 with digiKam Version 3.5.0 unter KDE 4.11.5

question: how to upgrade to the newest digiKam version

can i do this via comandline or YAST2 ?

Yes, the latest digikam version is always available in the KDE:Extra repo.

If you haven’t done so already, add it in YaST->Software Repositories->Add->Community Repositories, or with:

sudo zypper ar http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1 KDE:Extra

Then install digikam 4.6.0 in YaST->Software Management (use the “Versions” tab below the package list), or with:

sudo zypper in -f --from KDE:Extra digikam

hello dear Wolfi,

many thanks for the quick reply. Great to hear from you!

well i think that i run into some trouble… see the following results:

Repository 'KDE:Extra' wird hinzugefügt ....................................................................................................................................[fertig]
Repository 'KDE:Extra' erfolgreich hinzugefügt
Aktiviert: Ja
Autoaktualisierung: Nein
GPG-Überprüfung: Ja
URI: http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1

martin@linux-70ce:~> sudo zypper in -f --from KDE:Extra digikam
Metadaten von Repository 'Packman' werden abgerufen ........................................................................................................................[fertig]
Zwischenspeicher für Repository 'Packman' wird erzeugt .....................................................................................................................[fertig]

Neuen Signierungsschlüssel für Repository oder Paket erhalten:
Schlüssel-ID: 27C070176F88BB2F
Schlüsselname: KDE OBS Project <KDE@build.opensuse.org>
Schlüsselfingerabdruck: 4E8E6DE2961F3083EAC5008627C070176F88BB2F
Schlüssel erstellt: So 31 Aug 2014 16:06:11 CEST
Schlüssel läuft ab: Di 08 Nov 2016 15:06:11 CET
Repository: KDE:Extra

Wollen Sie den Schlüssel (a)bweisen, ihm (t)emporär oder (i)mmer vertrauen? [a/t/i/? zeigt alle Optionen] (a): i
Zwischenspeicher für Repository 'KDE:Extra' wird erzeugt ...................................................................................................................[fertig]
Daten des Repositories laden ...
Installierte Pakete lesen ...
Installation von 'digikam-4.6.0-36.1.i586' aus Repository 'KDE:Extra' wird erzwungen.
Paketabhängigkeiten auflösen ...

Problem: digikam-4.6.0-36.1.i586 benötigt kipi-plugins >= 4.6.0, was aber nicht angeboten werden kann
  Nicht installierbare Anbieter: kipi-plugins-4.6.0-36.1.i586[KDE:Extra]
Lösung 1: Folgende Aktionen werden ausgeführt:
  kipi-plugins-4.6.0-36.1.i586 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
  libkface3-4.6.0-36.1.i586 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
  libkgeomap2-4.6.0-36.1.i586 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
  kipi-plugins-acquireimage-4.6.0-36.1.i586 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE
  kipi-plugins-geolocation-4.6.0-36.1.i586 installieren (mit Anbieterwechsel)
    openSUSE --> obs://build.opensuse.org/KDE                                                                                                                                       
  kipi-plugins-lang-4.6.0-36.1.noarch installieren (mit Anbieterwechsel)                                                                                                            
    openSUSE --> obs://build.opensuse.org/KDE                                                                                                                                       
  libkgeomap-lang-4.6.0-36.1.noarch installieren (mit Anbieterwechsel)                                                                                                              
    openSUSE --> obs://build.opensuse.org/KDE                                                                                                                                       
Lösung 2: digikam-4.6.0-36.1.i586 nicht installieren                                                                                                                                
Lösung 3: digikam-4.6.0-36.1.i586 beschädigen durch Ignorieren einiger Abhängigkeiten    

sorry for the German language.
note: how can i tell my terminal - to talk english for all the time…!?

Choose Solution 1, allow the vendor changes.
zypper doesn’t switch packages to other repos by default (I thought you knew that… :wink: ), you have to allow this explicitely.
And digikam needs some other updated packages from KDE:Extra as well. Actually digikam is split up into a few packages, the kipi-plugins, libkface, and libkgeomap are used by other applications as well (gwenview e.g.), and it would be bad if those other applications require you to install the whole digikam…

note: how can i tell my terminal - to talk english for all the time…!?

E.g.:

export LANG=C

This only applies for the current terminal/shell and all applications started from it.

For a single command, you can do this:

sudo LANG=C zypper in digikam

You can use any other language you like, e.g. LANG=en for English, or LANG=en_us for American English specifically. LANG=C means to use the strings included in the applications themselves (normally english).

hello dear Wolfi

many thanks - now all digikam-things are updated.

you helped me alot

have a great day

greetings

dilbertone;)