How to change yast community from 11.3 to 11.4 for repositories?

I did zypper dup to move from 11.3 to 11.4. Almost everything works fine. But when I try to add community repositories I get the 11.3 repositories, not the 11.4 repositories.

So there must be a .conf or .rc file somewhere telling yast that we’re on 11.3 when in fact we are on 11.4. How/where can I change that?

And while we’re at it, how do I load a Factory repository? They do not appear in the list of Community" repositories.

TIA, Andy

Try with terminal

su
# zypper addrepo -f <URL of Repository>
# zypper refresh

On 2011-03-20 21:36, alavarre wrote:
>
> I did zypper dup to move from 11.3 to 11.4. Almost everything works
> fine. But when I try to add community repositories I get the 11.3
> repositories, not the 11.4 repositories.

cat /etc/SuSE-brand
rpm -qf /etc/SuSE-brand

> And while we’re at it, how do I load a Factory repository? They do not
> appear in the list of Community" repositories.

So that you do not load them by accident >:-P


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Carlos, Stamos thank you…

>P1630:/ # cat /etc/SuSE-brand
openSUSE
VERSION = 11.4

>P1630:/ # rpm -qf /etc/SuSE-brand
branding-openSUSE-11.4-2.1.noarch

But when I use
yast2 sw_single &
==> Configuration ==> Repositories ==> Add ==> Community Repositories ==> Next ==>
all I see are 11.3 repositories.

I can use most of them by simply editing 11.3 to 11.4 and enter them in the URL option, but the Gnome repos don’t convert, e.g.,
Index of /repositories/GNOME:/Apps/openSUSE_11.3

So there is something somewhere that doesn’t know I’ve upgraded to 11.4.

Have a great weekend!!

I have a friend who is going to Madrid, Huelva, and Sevilla this weekend and next week. Where are you?

Saludos, Andy

alavarre wrote:

>
> Carlos, Stamos thank you…
>
>>P1630:/ # cat /etc/SuSE-brand
> openSUSE
> VERSION = 11.4
>
>>P1630:/ # rpm -qf /etc/SuSE-brand
> branding-openSUSE-11.4-2.1.noarch
>
> But when I use
> yast2 sw_single &
> ==> Configuration ==> Repositories ==> Add ==> Community
> Repositories ==> Next ==>
> all I see are 11.3 repositories.
>
> I can use most of them by simply editing 11.3 to 11.4 and enter them in
> the URL option, but the Gnome repos don’t convert, e.g.,
> ‘Index of /repositories/GNOME:/Apps/openSUSE_11.3’
> (http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_11.3/)
>
> So there is something somewhere that doesn’t know I’ve upgraded to
> 11.4.

I was seeing that same thing until I finally ran “zypper dup”. There were a
couple of “openSUSE” files that were selected there and after that update
the 11.4 repos were offered. I figured it was a side effect of going thru
all the RC versions before that file got updated and I can’t put my finger
on which one it was but using Yast and searching on “YAST” and/or “openSUSE”
will show a file with a new version not offered by the update option unless
you manually select it. I had put off the zypper dup waiting for the
packman repos to settle down so that I didn’t get a boatload of code
switched from packman to the default repos but I just happened to catch that
one file when checking the update/upgrade list when I ran zypper (or they
finally got around to posting an updated community file list??).


Will Honea

On 04/02/2011 06:20 AM, Will Honea wrote:
> or they finally got around to posting an updated community file list??

in my feeble mind, that is the most likely…

it seems to me that there were more little things not quite ready
for release day this time, than usual…

i don’t recall them all now but a precise google will find (i think)
many old heads here answering many “why can’t i find [some package]”
with admonisions to be patient, they will show up…eventually…

not sure but i think The Community has more hand work than hand
workers…[and, instead of focusing on the basics there is a recent
tendency to fractionate and serve everyone’s dream, a la education,
tumbleweed, evergreen etc]


CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

On 2011-04-02 01:06, alavarre wrote:

>> P1630:/ # cat /etc/SuSE-brand
> openSUSE
> VERSION = 11.4
>
>> P1630:/ # rpm -qf /etc/SuSE-brand
> branding-openSUSE-11.4-2.1.noarch
>
> But when I use
> yast2 sw_single &
> ==> Configuration ==> Repositories ==> Add ==> Community
> Repositories ==> Next ==>
> all I see are 11.3 repositories.

Dunno, then.

> So there is something somewhere that doesn’t know I’ve upgraded to
> 11.4.

You could check the entire list of installed rpms in yast package
management, there may still be one that is from 11.3.

> I have a friend who is going to Madrid, Huelva, and Sevilla this
> weekend and next week. Where are you?

The other corner, Murcia.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Mmmm. Not good: I had already done zypper dup, but just for grins started it again (without an ampersand!) which rendered

173 packages to upgrade, 15 to downgrade, 10 new, 13 to reinstall, 1 to remove, 165 to change vendor, 5 to change arch.
Overall download size: 262.5 MiB. After the operation, additional 104.9 MiB will be used.
Continue?

Well, the packages to be downgraded included libreoffice and opensuse 11.4:

**The following product is going to be downgraded:
openSUSE 11.4
**

So a quick Ctrl-C put paid to that.

Obviously this occured because of whatever obscure file is still telling yast and zypper that I’m on 11.3 with ooo instead of what is true: 11.4 with LibreOffice.

Maybe after finishing taxes I’ll try this, but not now.

Thanks for the feedback.

Cheers, Andy

On 04/02/2011 05:36 PM, alavarre wrote:

hi Andy, please show us the output of entering the following into a
terminal


zypper lr -d

and copy/paste the output back to this thread using the instructions
here: http://goo.gl/i3wnr


CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

That downgrade of 11.4 will not cause any problems. Just let it happen.