How to change Time and Language?

Hey Forum.
Im new in Suse.

When i installed, i set Danish as my default language. I would like to change that to english. How do i do that?
Also, the time on my deskop is always 10 minutes to fast… And i really dont know how to change it? I can change the time zone, but that dosnt help…

Can anybody help?

Kind Regards.
Rune

Can’t help on the language change but the time thing sounds as if the hardware clock is off. Time zones and daylight saving schemes are all integer numbers of hours. You can set the time in Yast - System- Date Time.

There is a difference between the sysm wide configured language and the one for evevfry individual end-user usiing his GUI (after all you could have users from different languages in your system couldn’t you?).

For system wide goto YaST > System > /etc/sysconfig editor,there open System _ Environment - Language and see if it helps you.

For the end-user I can only tell you how in KDE, when you use Gnome, state this and ask further. In KDE there is the normal System setings and then in Personal you see Country/Region language (but in Danish in your case).

I assume you have set your time zone correct at install. When the system is “is always 10 minutes to fast”, does this mean it is allways 10 mins early after every boot, or 10 mins per day/hour? Not very clear, buut it looks like a hadar failure. In any case you should use an NTP server to correct the normaly small error of your hardware clock. YaST > Network services > NTP configration.

@gogalthhorp. It is not true hat time zones are integer numbers (of hours differing from ZT), also you may state that then it is no real time zone. But several countries have offsets that end in 30 mins. And Nepal ends in something like 40 mins. There may be more

gogalthorp wrote:

>
> Can’t help on the language change but the time thing sounds as if the
> hardware clock is off. Time zones and daylight saving schemes are all
> integer numbers of hours. You can set the time in Yast - System- Date
> Time.
>
>
If internet connection is no problem synchronize with a ntp server.
It is described in the opensuse reference chapter 25 which should be
installed by default in
/usr/share/doc/manual

For the languge: Did you look at yast -> system -> language?

On 2010-08-06 17:06, hcvv wrote:

> For the end-user I can only tell you how in KDE, when you use Gnome,
> state this and ask further. In KDE there is the normal System setings
> and then in Personal you see Country/Region language (but in Danish in
> your case).

Gnome and terminal:

Create file “.i18n” on your home.
However, there is a bug in 11.2 preventing it working correctly.
However-bis, it is possible to correct that wrong behaviour.

KDE perhaps can make use of this file, but perhaps not.

The file can take simple or complex settings. For instance, my default is English, with some changes:

cer@Elessar:~> cat .i18n

used by /etc/profile.d/lang.sh

LC_TIME=en_DK.UTF-8
LC_MONETARY=es_ES@euro
LC_PAPER=es_ES@euro
LC_TELEPHONE=es_ES@euro
LC_MEASUREMENT=es_ES@euro
LC_NAME=es_ES@euro


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

Carlos E. R. wrote:

> Gnome and terminal:
>
> Create file “.i18n” on your home.
> However, there is a bug in 11.2 preventing it working correctly.
> However-bis, it is possible to correct that wrong behaviour.
>
> KDE perhaps can make use of this file, but perhaps not.
>
>
> The file can take simple or complex settings. For instance, my default is
> English, with some changes:
>
> cer@Elessar:~> cat .i18n
> # used by /etc/profile.d/lang.sh
> LC_TIME=en_DK.UTF-8
> LC_MONETARY=es_ES@euro
> LC_PAPER=es_ES@euro
> LC_TELEPHONE=es_ES@euro
> LC_MEASUREMENT=es_ES@euro
> LC_NAME=es_ES@euro
>
>
If one wants to change the language only per session and uses gdm as login
manager you can also simply select another language from the language
selector (it is visible at the bottom of the gdm screen as soon as you
select the user you want to login).

@gogalthhorp. It is not true hat time zones are integer numbers (of hours differing from ZT), also you may state that then it is no real time zone. But several countries have offsets that end in 30 mins. And Nepal ends in something like 40 mins. There may be more

Really I did not know that. But I should not be surprised, there is no end in how politicians will screw around with clocks :slight_smile:

Correct. But some of these are quite understandable. In India for example, the half hour line runs through about the midst of the country. Using this instead of two different times seems to be logical.

Pakistan then lies on and hour (half an hour later). And Afghanistan is again half an hour later.

Nepal is realy odd with: UTC/GMT +5:45 hours (that is 15 mins against India). IIRC it was even something like 10 or 12 mins against India in the past. In principle. being a Hindu kingdome in those times, it used Kathmandu solar time.

China of course choose for one overall time based on Beijing. Giving strange sunrises/sets in the very west of the Peoples Republic.