How to change the boot splash screen

My main question before go into rant mode again is how can I change the splash screen and boot and shutdown. It is the ugliest thing I have ever seen and drives me to want to put opensuse in my personal trash pile alongside Ubuntu, well all Debian derived distros including Debian. Desipte my complaints I do like opensuse(mainly because it has a good KDE setup and YAST-seriously, if only some of the equal to or better than opensuse would steal YAST…) and really don’t want to change since I am old and curmudgeny. So pretty please, can someone help me out?

Any help is greatly appreciated!

I have been fairly surprised how well 12.2 runs, given the chaos. It is nowhere near perfect. It uses a bit more memory than 12.1(the only valid justification for more memory usage is more productive apps(which there are no new ones) and significantly better preformance which is not the case. It still has the issue of about 20 akonadi servers spinning up for no apparent reason and taking over 60MB of RAM on its own and of course all dev tools are ancient, requiring a ton of work to get a usable dev environment running, but I am used to that.

Also why does 12.2 KDE want to install Apache and a few PHP libs by default? I clicked them all off during install and now YAST keeps wanting to install it! Why would a web server be needed on an average users desktop. Please don’t say that it is there so those that need it can easily get it, since that is the exact opposite of the reason I was given why opensuse refuses to make up-to-date, sane dev tool choices.

YaST > System > Boot Loader > Boot Loader Options > Console theme

Simplest: go to “/boot/grub2/themes/” and copy the default “opensSUSE” folder to e.g. “newBootTheme”, then change e.g. “newBootTheme/background.png” etc.

Re rant: your complaints seem to be peculiar to your installation/chosen configuration. I have no problems with errant apache/php, memory consumption c.f. 12.1 or akonadi (one instance each of akonadi_control and akonadiserver).

@Eiledon

I don’t like the default blue vertical display either

another way to change it :-

cmd
systemsettings

under ‘System Admistration’ choose ‘Login Screen’

  • make sure ‘Use themed greeter’ is not checked
  • in Background tab
    – select Picture and then go to the right and click on the file/directory icon
    – navigate to /usr/share/kde4/apps/ksplash/Themes/
    – then select in one of the sub-directories the background.png of your choice
    — or any other suitable .png file

when chosen select OK and then Apply
root password is then asked for to make the change permanent

by this method, if you are using more than one screen, a different background
can be chosen for each

They did not install here. Perhaps they are dependencies of something else that you installed.

Thanks for the information. Maybe it is the 64 bit DVD being wierd about Apache. /shrug The akonadi_agent_launcher is the culprit and was in 12.1 and I am certainly not the only one with that issue.

I never install the awful kde pim or kmail and the only program I use(rarely) that relies on it is kgpg so it should not be an issue but is because of bloated packages like akonadi-runtime(which contains the offender akonadi_agent_launcher) and libaknadi4. Bit and pieces of the libs are used by actual useful software so I can’t ditch things.

Unfortunately, that is not the case.