how to change sddm to kdm and reverse

on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
upgraded 13.2 to leap 42.1, using wolfi repos I’m running KDE 4.14.16 and plasma 5.5.4
running plasma5, at the first login after boot I have KDM login manager
if I logout and login again or lock screen appear another login manager that seems SDDM
so I would like to try SDDM and have the possibility to come back to KDM if I dont like it
using systemsettings 5.5.4 >startup and shutdown>login screen (SDDM) I have no choice to change it in KDM, where I can change it??
and it seems to be incoherent:
looking at yast>/etc/syscongig editor>desktop/displaymanager:
DISPLAYMANAGER is set to kdm
in the entries there isn’t sddm, if I want sddm what I have to insert?? is sddm ok??
manythanks :slight_smile: ciao :slight_smile: pier

If that DISPLAYMANAGER variable is set to “kdm” then you should be running “kdm”.

Well, that assumes that “kdm” is actually installed on your system. I’m not sure what happens if you configure a displaymanager that is not installed. I’ve never quite dared to test that.

When you logout from Plasma 5, the logout screen looks very similar to the “sddm” login screen.

Personally, I am using “lightdm”.

@pier_andreit, can you please in the future try to start sentences with a capital letter and end them with a . (dot). It makes reading so much easier for those who may be able to help you. Remember that not all here have English as their first language, but nevertheless may have a a lot of openSUSE knowledge. Thus make it easy for them to understand you.

Sorry, you are right :slight_smile:
On my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, upgraded 13.2 to leap 42.1 using wolfi repos; I’m running KDE 4.14.16 and plasma 5.5.4.

Running plasma5, at the first login after boot I have KDM login manager.
If I logout and login again or lock screen appear another login manager, that seems SDDM.
So I would like to try SDDM, and have the possibility to come back to KDM if I dont like it.
Using systemsettings 5.5.4 >startup and shutdown>login screen (SDDM) I have no choice to change it in KDM, where I can change it??
And also it seems to be incoherent:
looking at yast>/etc/syscongig editor>desktop/displaymanager:
DISPLAYMANAGER is set to kdm.
In the DISPLAYMANAGER entries there isn’t sddm, if I want sddm what I have to insert?? Is sddm ok??
Manythanks :slight_smile: ciao :slight_smile: Pier

… I installed it and will try :slight_smile:

Yes, setting that to “sddm” should be fine. Maybe first make sure that “/usr/bin/sddm” exists.

For me, “sddm” is an offered option. But maybe when you do an update of 13.2 instead of a clean install, you only see the options that were available for 13.2.