How to change display refresher rate?


I have the following problem: My monitor (no flat screen) allows me to use a display refresher rate of 100 Hz at a solution of 1024x768 px, it consequently has to be flickerfree, and so it is under Win XP. Under Linux (opensuse 11 KDE 4.0 Desktop) there is always a slight flickering. How can I set the display refresher rate durable to 100 Hz? I tried to use Yast and changed the frequency ranges to 80, 95 and 100, but the lower limit is always resetted automatically to 74 Hz. Can you help me?

Thanks in advance,


did you note (in YaST) if your exact graphics card and monitor was
found? if both were not, see if you can find and select the exact model
on the list offered in YaST…then you will get to run through some set
up screens and presto, be happy (maybe) :slight_smile:

DenverD (Linux Counter 282315)
A Texan in Denmark

*Problem: *My monitor allows to use 100 Hz at a resolution of 1024x768. But KRandRTray did not show this option, the highest selectable rate was 85 Hz. SAX displayed right monitor and video card. Although 85 Hz should be flickerfree, there was nevertheless a slight flickering. I searched the web and found some possible solutions. The following instruction is supposed to work with

openSUSE 11.0
KDE 4.0

:stuck_out_tongue: Warning: If you try this, you do it on your own risk. Check screen handbooks and find out which refresher rates are allowed before trying.

:eek: Some visited websites told me, that using wrong refresher rates may cause damage to your monitor!

Possible solution:

Open terminal and enter

xmode -x 1024 -y 768 -r 100

You will get the corresponding modeline:

Modeline "1024x768" 113.31 1024 1096 1208 1392 768 769 772 814

Copy the last line and open


Look for
Section “Modes”
and paste the modeline into a new line right before the end of the section. If a modeline identified by “1024x768” already exists, replace it. Go to section “Screen”, find the right color depth and add “1024x768” to Subsection “Display”, line “Modes”. If the entry already exists, do nothing. Save file and reboot.

Of course you can adapt this method for other resolutions and refresher rates.

I think, I found a similar instruction within openSUSE online help, but unfortunately I did not bookmark it and did not find it again.

:eek: Please post a reply if there is something wrong or dangerous with this method. However it worked fine with my system.