How to change both trash icons full and emty

hi all,

i have googled how to do this but i cant seem to get a proper answer , is it possible to change the trash icons on os 11.1 becuase everything i have tried has not worked.

thanks

Both KDE and Gnome support icon themes. Applying a theme in Gnome requires that you download the theme (normally a .bz file from such web sites as Eyecandy for your GNOME-Desktop - GNOME-Look.org) and drag and drop it into the theme manager (Slab menu - Control Centre - Appearance).

As you wish to replace individual icons you need to know if the icon theme is a standard one or a customised one.

Can you advise whether

a) You use Gnome (then I might be able to help more)
b) You use a standard theme or not (if not the location of the icons is <your_home_directory>/.icons)

Cheers

wooops sorry forgot that, im using gnome and its a customized theme

Well you are mostly there then.

In your home directory is a “hidden” directory called .icons

In there will be a directory with the name of your theme, e.g. hydrogen

In that directory will be a number of directories, which dending on your theme will be named according to size of the icons, e.g. 48x48, in each of these “size” directories will be another directory called “places”. In there will be icon files (png files - easily edited) and the ones you are interested in are:

gnome-fs-trash-empty.png
gnome-stock-trash.png

It is possible that these files are “symbolic links” (Windows speak = shortcuts), for example in my setup they are links to user-trash.png. If they are links just replace the file that they point to (if you are not sure how to identify a link then look for a emblem on the icon that represents an arrow or right click on the icon and choose properties and the page that comes up will tell you if the file is a link) (sorry if I’m going over the top with info, but I don’t know how much you know).

Once you have replaced the icon files you will then need to update the icon cache. To do this open a terminal window (right click on the nautilus background and choose “Open In Terminal”) then…

<code>
cd …
gtk-update-icon-cache <name of directory that is your icon theme>
exit
</code>

After a few seconds (can be a lot more if your theme has a lot of icons), you would have been returned to the prompt, and its at that point you type exit.

As the cache is updated you should see the change take effect.

Good luck.

BTW I’m always missing off vital bits of info when I ask a question so no problems for me when other people do.

thanks for the reply , but when i show the hidden folders and go to .icons there nothing in it!

Hmmm…it does look like you haven’t got a customised icon theme. No matter, the directory you are looking for then is

/usr/share/icons

In there are the directories matching the standard themes supplied.

Sorry for the delay getting back to you, my internet connection has been down for a while.

Cheers

Thats ok np i will give it a try

thanks for your help :wink:

Did you get anywhere?

Just for info, in kde 3.5 if you change the .png files in usr/share/icons/<theme-name>NNNxNNN the update is automatic.

In my KDE install the <theme-name> is “gnome”… I think the chosen theme is copied to this directory.

I have a similar issue. Noob here so sorry! I have suse 11 think I am downloading gnome themes from gnome-look. I download the tar file to /tmp and from there i go into computer>personal settings>appearance>icons. From there I install theme file and go to /tmp/THEME_NAME.tar.gz and install it. It does appear to install but only a few of my icons change. The standard firefox, pidgin etc don’t change. So I want to change them individually.

I go to /usr/share/icons/ and I don’t see the theme folder i just installed. Just the default themes. Also in my home folder under .icons its empty for me as well. How can I change just the individual icons now?

Thanks again!!!

Hi
Just put the tar.gz file in your ~/.icons directory and unpack there.
You should have a folder as the theme name, with lots of sub-directories
with the different icon sizes?

Then just open the Control Center -> appearance -> customize button and
select the icon tab and scroll down the list to select.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 3 days 1:05, 2 users, load average: 0.64, 0.57, 0.28
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

alright, i can download an icon theme, desktop theme and it doesn’t work if i have it untar’d or unzipped. but i can load it if its still tar.gz’d. but again it changes the colors of the windows, and borders and some of the fonts but the default fonts of says firefox, pidgin doesn’t change. Am I suppose to go into those directories and change?

I downloaded the icon theme to /.icon and unzippd but wasn’t able to load or should say nothing was listed in computer>appearance>icon. I didn’t notice the customize after appearance button. Am i missing something? thanks again from the Noob! :slight_smile:

Hi
If there is a folder under ~/.icons it should appear in the Icons tab
after pressing the customize button in the following screenshot;

http://thumbnails23.imagebam.com/5739/e13ca457380430.gif](http://www.imagebam.com/image/e13ca457380430)


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel 2.6.31.5-0.1-desktop
up 5:29, 1 user, load average: 0.10, 0.07, 0.04
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME