How to change background color of bottom Panel?

It seems that every install of openSUSE seems to have a different color to the bottom Panel. I just hate this dark gray background I’ve got with 12.1. I can’t seem to figure out where to change this? There doesn’t appear to be anything in Panel Tool Box.

On 11/27/2011 08:26 AM, stubble wrote:
>
> I just hate this dark gray background I’ve got with
> 12.1. I can’t seem to figure out where to change this? There doesn’t
> appear to be anything in Panel Tool Box.

the color of the panel is set according to the desktop theme selected
(in Configure Desktop > Workspace Appearance > Desktop Theme)…

WAIT, that is most likely only true in KDE and you didn’t mention the
desktop environment you are using so . . .

please, when asking for help include this as minimum:
-operating system and version
-desktop environment and version


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!

I’m using openSUSE 12.1 with whatever version of KDE comes as standard with 12.1. I didn’t find anything in Config Destop, to make it a transparent Panel. Perhaps you could point me at where I find this option? Or any color other than dark gray.

Composting needs to be enabled for transparency to work.

Try changing your desktop theme in systemsettings -> workspace appearance. Desktop themes are either transparent or not, individual elements of a theme can be changed to a different desktop theme that has transparency using the details tab but transparency is not switchable. iirc the air themes are transparent.

I’m using air, but it’s not transparent. Well the buttons are transparent, but the background is a dark gray. By transparent I mean the background is see-thru to the Desktop Image beneath it. But a light grey background would be ok. with the dark-grey background, you cannot read the text on the buttons or clock, clearly.

The colour of the panel is dependant on the setting in the Plasma Workspace > Desktop Theme
Effects need to be ON for transparency and the most transparent is Glassified
But to get that Theme requires: Index of /repositories/KDE:/Extra/openSUSE_12.1
repo to be added

On 11/27/2011 03:06 PM, stubble wrote:

> cannot read the text on the buttons or clock

still don’t know what desktop you are using, so i don’t know what to
tell you–but on mine i can change the color of the clock font…

hmmmm, i don’t have any buttons on my panel with text in them…so,
that i don’t have a clue…


DD http://tinyurl.com/DD-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!

@DenverD - I said I was using the standard KDE desktop that comes with 12.1. Or am I missing something in your question?

@cafe4926 - OK. I downloaded the Glassified Theme. I now have 5 themes installed. The 3 that come with 12.1, Air, Air for Notebooks, Air openSUSE, the Glassified them I just downloaded, and a (Customized) Theme. I’m not sure where the last one came from, how to select/delete it, but it has everything as Air except Panel Background is Glassified. Now miraculously my Panel Background has turned from Dark Grey to Mid Grey. Everything is much better now, but it’s still not transparent (showing the Desktop Image through the background).

But I have a question. How do you select between the Themes? Is is unclear for me. I am uncertain about which theme I’m using when I boot up.

There is also a package
kdeartwork4-desktopthemes
install it

On 11/27/2011 04:06 PM, stubble wrote:

> @DenverD - I said I was using the standard KDE desktop that comes with
> 12.1. Or am I missing something in your question?

ah, so you did…i read it and forgot it…that fast! sorry.

>
> But I have a question. How do you select between the Themes?

the path in KDE4.6.0 (older than yours which i think is about 4.7.x) is:

Personal Settings - Configure Desktop > Workspace Appearance > Desktop
Theme, and click on the theme you want to use (background changes from
white to light blue [here, it may be different on yours] then click on
“Apply” button…


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!

@caf4926 - Installed. Not exactly sure how I preview these themes (I’m not a theme guru) :slight_smile:

@DenverD (or anyone) - When I switch between the (Customized) Theme (Air Theme but Glassified Panel Background) and Air Theme, I don’t see any difference on the Panel Background at the bottom. I am Applying the Theme each time. Sometime I get a pop-up asking me to confirm the changes, sometime not. And I can’t tell why I get that message sometimes and other times not. But either way, I don’t see any difference in the Panel Background. Perhaps it’s because Composting isn’t enabled, as google01103 said. Where to turn that on?

To add to DenverD…

Configure Desktop > Workspace Appearance > Desktop
Theme, and click on the theme you want to use. There is another tab next
to the Theme tab called Details. Select the Details tab and select the Panel
Background you want to use. I use Air for netbooks Panel Background and
it is fairly transparent. Select the “Apply” button to see your changes.

I think I’ve applied the themes both on the first page and the details page, and never see any difference to my Panel Background, whichever Theme I use. Could this be because I don’t have Composting turned on? how do I turn it on by default?

Alt+SHIFT+F12 will toggle it on

System Settings > Desktop Effects and check the Main option for Activation 'Enable Desktop Effects

The ‘All Effects’ tab lets you configure details

This page: SUSE Paste
Lets you configure aspects of the Desktop theme