How to change back to VESA-driver?

I recompiled the new ATI-driver into the kernel. The new driver didnt work and it only freeze the computer(Acer TM4001WLMi).

I need to go back to the default VESA-driver, but “sax2 -r -m 0=vesa” doesnt work. I cannot remove the ATI-driver since it also semove Sax2 and X.

How can i go back to the vesa-driver?

sax2 -r -m 0=vesa

needs to be done, I would recommend out of X and if it were me, I would boot to level3 user, go su and run the command.

I did so!
I enter “3” in Grub and boot into init 3. Then i login as root and enter “sax2 -r -m 0=vesa”, but then it freeze when it try to start Sax2 in X.

Is it possible to remove the ATI-driver from the kernel?


Boot to the CLI and and either use

or zypper
Zypper/Usage/11.1 - openSUSE

It seems nothing work! If i run Sax2 -r -m 0=vesa, then only a CLI-vresion of Sax2 start. I uninstall “fglrx”, but it also uninstall Sax, and if i try to install Sax2, then it install “fglrx” back again. The driver “vesa” seems to have disapears completly.

I was testing with Ubuntu 8.10 Live to see if Ubuntu have better driver, but Ubuntu crash completly. Even i Safe-Graphic-mode.
I see Ubuntu find and identify my ATI-card as “RV350 - ATI Radeon 9600 M10”, but OpenSUSE says “RV350 NP - ATI Radeon 9700”. I guess the Gfx-chip is called RV350.
This GFX-card is completly Non-Linux. None of Linux distro i’ve tried do support this ATI. Only OpenSUSE manage to isntall the “vesa” to run in 1024x768 24bits, but then without any GL-support.

I get tired of this and reinstall OpenSUSE so i get back “vesa”. What a crap Gfx-card!

Yeah, then my laptop (Acer Extensa 3000 WLMi) with exactly the same card which worked with 3D since openSUSE 10.2 (with minor tweaking) and “Out of the box since” 10.3 by using the free driver “radeon” must be a fata morgana.

(And of course also the Travelmate 4000 WLMi of a good friend of mine using exactly the same setup with 3D and free radeon driver…)