How to burn iso CD with k3b - V2.02 in Kde 4.6.0 on OpenSuse 11.4

I have 3 iso images I downloaded that I would like to burn into CDs.

Just clicking on an iso file brings up k3b. Each of the files brings a different k3b reaction, but none of them burn.

As a good test file to get k3b working, I downloaded the live gparted iso. The first time I tried to burn this, I got some k3b comment to the affect that i could fix the problem by changing my permissions.

After looking at the half-dozen groups and applications, thought I would ask for help. On this list, I see the k3b log mentioned, so I reran the burn to get a log file. This time, no error, but an endless loop running the DVD drive, but not making any marks on it. I canceled that attempt and grabbed the log.

I believe that I have updated k3b since I installed 11.4, but now if I try that, I get something like umgalartin is not available! This has happened at several times I’ve tried, but that is another problem.

Is there some guide as to what permissions need to be changed from the default to burn iso CD? There is also a checkbox unchecked to use the burning group.

Besides the log I captured from the endless looping case, I did get a jpg image of the burn menu that mentioned the protection problem.

Let me leave this here and see what kind of response I get. Heboland

Open k3b
In the menu > tools > burn image
select and burn

i have only recently experimented with kde4-k3b, since kde3 version had been used reliably previous… and i got that “permissions” popup with my first burn and was confused… set the iso tool from Auto on the right to geniso and viola~ no more worries… except that the file list editor is not as handy as previous.

everything burned perfectly after with no war on permissions at all.

Thanks for the responses guys!

J_Xavier, when I go to tools > burn image I see the Image Type pulldown in the upper right corner of the burn image menu.

The default is apparently Auto Detection. There’s no geniso in the dropdown list. My choices are:

Plain data image
Cue/bin image
Audio cue file
Cdrdao TOC file
Cdrecord clone image

If I look at k3b > settings > Programs I see the mkisofs has a check for the path /usr/bin/genisoimage with a version of 1.1.10.

One other datapoint that might be useful to me is how much time should it take to burn the gparted live CD image which is about a 100MB iso?

If this is an hour’s job, maybe my “endless loop” described above was accomplishing something besides incrementing the clock. I canceled the burn after about 4 minutes.

Nothing was showing in either of the progress bars. Heboland

What version of K3b do you have? – mine is 2.0.2
In the settings menu there is an item “Setup System Permissions”
This shows the permissions it recommends changing and makkes it easy.

Thank you eng-int.
I also have 2.0.2 Release 6. I just updated it, so it should be up to date.

Yes, I found the suggested permissions. I didn’t check the burning group, but I did check the other suggested permissions.

I seem to be getting closer to making it work. Now I’m getting Errors like this:

Try 1 Using Tools > Burn image > Write Mode Auto

cdrecord returned an unknown error (code254)
Sometimes using TAO writing mode solves this issue

Try 2 Using Tools > Burn image > Write Mode Mode 2

Unable to fixate the disk
The disk might still be readable
Try DAO writing mode

I don’t know how to relate the writing mode number to handle k3b gives such as TAO.

Also, does k3b know if a CD is blank? Are all of these failed attempts creating CD coasters that are not reusable or can k3b tell if if a CD is not suitable for an iso image? Heboland

Replying to myself, k3b can tell a blank CD. Using a disk that had failed to burn, i was able to burn the gparted iso. This time I did select Verify for the first time, but I doubt that contributed to the burn success.

Now I come to something I would appreciate a response on!

The other two iso files I downloaded get this response in red from kb3:

“Seems not to be a usable image”

So is this the end of the line for these files, or are there converters that can transform unusable iso images to useable one?

For the record one unusable image file name is:

This is supposed to be a file that will reproduce the CD that shipped with Actiontec modems. Heboland

Most .iso files will have a check sum in order to verify their authenticity and completeness.
If you didn’t download them with a download manager that is able to stop/start the download, then you may have to download them again. In the case of bittorrent, it is possible to import the downloaded .iso, where you can then force a re-check of all it’s pieces.

I read a thread recently were someone was singing the praises of ImageBurn. A windows burning program, they were running in wine, which apparently works brilliantly. You should find it available at filehippo. Just a though.

“Verify” computes the md5 checksums of the originating iso and from reading the newly burnt disc, then compares them. It detects bad media, or something going wrong with the write process. It takes longer but is useful before giving the disc to someone else.

I downloaded that iso from and was able to burn a CD (15.1MiB of data). Actiontec do not provide checksums for any of their downloads. My md5sum was:
b185e17077e13dfca8512f87623a43c3 CD_0410-0111-000_NCS_EX560LKU.iso

However it does not seem to contain a filesystem, and is thus useless. Other .iso images that I checked from Actiontec were similar. Using Dolphin (assuming kio_iso is installed – which is the default); if you right-click on an iso image file, you can choose Actions > Browse ISO when it will auto mount -t iso9660 -o loop,ro in tmp, and let you view/copy its contents. This works for all the other .so images on my system, but not for Actiontes’s.

I think they meant ImgBrun and yes it is the best burning program I’ve seen but I only run it under Windows.
The Official ImgBurn Website
I prefer k3b on Linux. Somehow I always prefer to avoid Wine.

Best regards,

Thank you caf4926, eng-int, glistwan!
eng-int, a special thanks for all the neat, detailed information.

Would you share how you were able to burn the Actiontec iso without it having a checksum?

My kio_iso was installed, but the browse iso line was missing from the dolphin > actions menu. When I updated kio_iso the browse iso line appeared. Then I saw the same thing you described.

The Actiontec isos have windows modem drivers & FW on them. Before long I will in modem only territory and wanted those contents.

caf4926, I did install ktorrent and tried to use it to download an Actiontec iso. My ktorrent hasn’t been verified by a known good iso yet, but it gave me this error:

An error occurred while loading the torrent /tmp/CD_0410-0111-000_NCS_EX560LKU.iso:
Illegal token: 0
The torrent is probably corrupt or is not a valid torrent file.

This thread is moving off the topic of k3b image burning. I was able to burn the gparted iso using k3b after changing permissions. I’m marking this thread solved! Heboland