How to boot my other distros in VirtualBox?

I presently have the following operating systems installed to my SSD:

  1. Arch Linux
  2. Gentoo Linux
  3. openSUSE Tumbleweed (OT)
  4. Solus
  5. Void
  6. Windows 10

My question is quite simply, how, when I’ve booted OT, can I boot my Void system in VirtualBox?

What I have tried already

I have seen this guide:, but following it lead me to this:

To be precise these are the steps I followed:

I ran:

$ xhost +
$ sudo su
# VBoxManage internalcommands createrawvmdk -filename "sda.vmdk" -rawdisk /dev/sda
# export DISPLAY=":0"
# VirtualBox

then in VirtualBox I created a new VM with sda.vmdk being its disk, 4 GB RAM, name Disk and everything else left at defaults. Then I tried to launch this disk VM and I received the above error.

If you’re wondering whether I should specify the specific partition on which void is (/dev/sda8) I’ve tried that and when I do that I get no bootable device errors.

If you’re also wondering /dev/sda8 isn’t mounted.

My Tumbleweed version is 20181022 and my VBox version is 5.2.18.

Every Linux system on my PC is using a ext4 partition, with no LVM.

Thanks for your time,

Lol I found the fix pretty quickly, I realized that VBox uses BIOS by default, not UEFI and my system uses UEFI to boot so I ticked the UEFI box in the VBox settings.

MB$ vs UEFI would be a critical issue for what you’re doing.
Beware pointing VMs to raw disks, there are good reasons why that’s never recommended in any virtualization technology and only more experienced Users who understand the issues might do that.
The risks of disk corruption goes up considerably, and usually relate to more than one OS modifying files because the usual protections isolating running OS are removed. You must intimately know not only the obvious but also the less documented background processes running in every OS you run. The fact that your raw disks have OS installed on them and the disks aren’t simply storage increases your risks further.

In other words,
Don’t do what you are doing if you value your systems. Don’t do anything you can’t afford to lose.


Yep, I learnt that the hardish way. I say hardish because I have a data partition that all my distros read and write from extensively. The data partition wouldn’t mount on boot when I rebooted my real (as opposed to virtual) Tumbleweed system; fortunately it just needed a little fscking before it would, with minimal lasting damage. It was good in that there was no significant lasting damage, but at the same time it gave me enough of a scare not to do it again. Thanks, however, mate it’s helpful that anyone that sees this thread in the future knows the risk.