How to block the update of gnome-shell 44?

Hello, I am a new user of open suse and quite new to linux.
Thank you to the people who manage this distribution because I am really happy with it.

The update to gnome-shell 44 has put me in front of some problems.
The extensions are not yet up to date of course.

But the big problem is that I can’t play my favorite games (apex/csgo) anymore:

  • on wayland the window opens with a shift in the top left corner with dashtopanel extension activated, and in the bottom right corner without.(and the hold win/alt key to move it ( as i set from tweakstools) doesnt work anymore
  • on xorg the window is invisible although launched, whether the extensions are activated or not.

While waiting for the problem to be solved or for it to be solved, ive rollback to a previous snap.
I now would like to keep my system uptodate except for gnome-shell.

Do you think its a good idea ? will i have issue doing this?
and is this the way to do it : Capture-d-cran-du-2023-03-27-00-07-34 hosted at ImgBB — ImgBB

(locking every installed gnome-shell packages from yast) and then keep updating.
I use this command to update once a day , i hope i do it right :slight_smile:
“sudo zypper ref && sudo zypper dup && flatpak update && sudo zypper ps -s”

i used a translation tool for the biggest part of this message, and i am not use to forums, so by advance sory if there is mistakes there.

@failafail8 Hi and welcome to the Forum :smile:
You don’t… just disable the extensions, you can manually edit the metadata.json files for extensions to add 44, in most cases they should work, if not keep disabled and wait for an update.

Look at creating a bug report for the other issues to get them resolved, just stopping a new release won’t help you (or others) in anyway…
openSUSE:Submitting bug reports - openSUSE Wiki

1 Like

thank you!
so, i should go there : ~/.local/share/gnome-shell/extensions
then on every extension folder i find the metadata.json file.

when i open a random one with gedit , i can read

"shell-version": [

i just add 44 like this ?

“shell-version”: [

if it wasnt what created the gaming window position issue, i’ll make sure to submit a report, thank you for the link and help

@failafail8 you need to add a comma after the 43…

“shell-version”: [
“43”, <====
1 Like

You can lock gnome-shell, but then you get error installing all dependencies that require this version. I do not know how many packages depend on (exact version) of gnome-shell, you need to test it.

Of course there could reverse issue - gnome-shell may depend on behavior that changed in newer GNOME release. Again, you won’t know without testing.

1 Like

ty, i worked for every one, except the dropdownterminal, wich isnt a big issue at all.

yes, ty. ive updated the entire system and tried to work around with borderless window, change of resolutions, tryin other games and more.
The more i tried the more i found issues with video games. i didnt check reddit yet but i found this Issues · GNOME / mutter · GitLab
i saw many of my issues here. people talkin about them in a very knowledgable technical way.

the very good point :
i love kdeplasma,but on any ditros it wasnt working on my weird tv resolution tho (736p), and now it does !!!

  • the fact that in opensuse you can have many desktop environnement in a single install.
    i’m spoiled :slight_smile:

i will still try to do a report just to learn, and who knows maybe it will still be helpfull. But i’ am switching to kde
edit: apparently it would be a dupplicate if i do a report. so i wont

@failafail8 I use ddterm here, as this also works with Wayland.

1 Like

apparently its the only one working on wayland. good for us, it seems to be a great one ( all i need is transparancy to keep an eye on big update while i watch tv shows)

So, finaly kde aint for me ( that dpi bug come again and again + like wayland and nvidia works great on gnome only)

i’ve tried and, i couldnt launch any session. wasnt a real solution anyway. i will stop my gaming addiction and try to find a solution or wait for it.

i guess this guy issue is related to mine

i’m waiting for my gitlab account to be confirmed to interact with him.
i have made the report here, it was pretty overwhelming to me (took me 2 hours, no joke) so i hope it is not too badly done.

the problem is solved by update, by reading the gitlab i guess it was a gtk issue with fullscreen window.

sadly i cant login into bugzilla to say that it is solved :frowning: