how to avoid root password prompt for encrypted usb key mount ?

I have been searching the forums for a clue but no success.
Each time i plug in my encrypted usb key, after password for encryption, kde/plasma asks me for root password. I think it’s useless and i did not have this problem with 15.2. I tried to find some polkit files to edit somewhere.
For example i wrote this in /etc/polkit-default-privs.local :

org.freedesktop.udisks2.filesystem-mount yes:yes:yes
org.freedesktop.udisks2.eject-media yes:yes:yes

But no success.
I know it’s a hack that i blindly copied and that it’s bad to act this way, but i need an efficient way avoid entering root password each time i need to save some normal but useful personnal datas on my removable storage device.

Though it’s not very polite to talk alone in public, i give the answer i found, so that it will be useful for anyone meeting the same problem in the future.

I added this line in the /etc/polkit-default-privs.local file :

org.freedesktop.udisks2.encrypted-unlock yes:yes:yes

And as suggested in this file , i ran the command as root :


And until now, the usb encrypted key mounts with the encryption password but without root password, as it used to work in suse 15.2.

Thanks for reading. And au revoir

And, to be fully correct , i have to write that the right line to add in the file is :

org.freedesktop.udisks2.filesystem-mount-system yes:yes:yes

And then, run as root :