how to automount external drives in KDE 4

Can’t find a setting for this . . .

I have an external USB Samsung Hard Drive.

It is permanently plugged in and when Opensuse 11.0 boots up it is loaded and can bee seen in Dolphin.

However, it is not mounted until I actually browse into it.

I can’t find any way to automount this drive.

In KDE 3.5.xx it was simply a matter of right clicking on the device icon and setting automount.

In KDE 4.0 there are no device icons loaded other than in Dolphin and there is no automount option to be found.

Can you help me out here??


Have you tried adding a line in your /etc/fstab? If it’s always plugged in when you boot, normally having that line in the fstab will mount it during boot up sequence. It might not be an automatic mount solution, but it would mount all the time without you doing anything, if that is what you are looking for?

Thanks for that

But surely there is a setting for this somewhere in KDE 4??

I can’t imagine it is something that would have been left out!

I’ll let someone else answer for KDE4, I am not using it yet and I have not tested that functionality during the beta tests. I must admit I’ve never used any function when it comes to automount, I always played with the fstab, command lines or editing files. Even in KDE3 I have no idea other than fstab.

I wish you luck and if you find that function, plz let us know. :slight_smile:

If I was to set an entry in fstab via yast2 what would I set as the mount point?

You need to create the folder for the mount point and you can set any folder you want.

/abc/19873128371 will work too!! Usually you assign a logical folder. By logical I mean logic, that makes sens, depending on your HDD usage.

It could be /EXTUSB or /mnt/EXTERNAL or /mnt/ExternalUSB or /USB/Samsung (if it’s a Samsung), etc., whatever you want, as long as you create, as root, that folder before you mount it. If you don’t do that, it will say the mount point does not exist and won’t mount it (if I recall that’s the error displayed).

In my case, I have an external USB/eSATA drive which I use as SATA and I have created 4 folders for all the partitions in it.


Only root is not mounted, I do not need it, cuz I rsync data between 2 drives and rsyncing root while it’s running on the source has not proven to be good for me. If I wanted the disk to be mounted at every boot, having those mount points in fstab would mount all of them during boot.

sorry - I’m a bit slow
I’ve never worked in fstab before.

But - if I go into the partitioner in Yast2 (which I understands writes to fstab without me having to edit it . .

My disk is already there as I have already mounted it.
However, as it was nto mounted on boot there is no entry in fstab - so from what I understand I need to set a mount point in Yast2 for it to write to fstab.

Is this correct?

Oh, that partitioner! Ok sorry, I very rarely use Yast.

Yes, the column MOUNT that’s where you have to assign your folder.

Select your partition, click EDIT and then at the bottom right (in 10.3 it’s at the bottom right) either select a mount point or type in whatever you want. This “whatever you want” refers to the folder suggestions I listed in my previous post. It’s a free format field.

Now I suggest you add a few FSTAB OPTIONS. Click on the buttom with that name. Select the NO ACCESS TIME. This is barely mandatory, apparently only in some rare cases when you manually compile certain packages. Check on ACCESS CONTROL LISTS and EXTENDED USER ATTRIBUTES as well, if they show as being available (depends of your file system). The 3 options are quite standard and well used.

Do not forget to create your folder (mount point) in your root! Using root privileges.

Let me know.

Thanks for that - it worked a charm.
I was a bit worried on the first boot after applying the changes as the drive churned for about 4 minutes before Suse resumed booting. However, seems like this was a one time thing as it has not done this on subsequent boots.

Any particular reason why I should not mount the drive in /Media or would it be fine to mount the drive in there?
Currently mounting /Samsung

Probably the disk churning thing is related to the fact fsck (an disk tool that checks data integrity) was scanning the disk for errors and integrity issues. If you boot in verbose mode (you see all lines of what’s happening during boot, drivers loaded, partitions mounted, etc.) you would see a line with a progress bar and % while it scans the disk. It is possible every 30 mounts (or 30 reboots) it will do that scan for integrity checks (default numer is 30). No worries there, if fact it’s a good thing!!! :slight_smile:

You can mount in /Media, I would use /Media/Samsung, though. It’s possible /Media is sometimes used by default when you plug in different kinds of drives, I never use directly /Media and /mnt, since those are too generic to me. But /Media/Samsung or /mnt/Samsung will have absolutely no impact whatever other drive you connect.

One last thing, always be careful when you play in the Yast partitioner. If you click on something without knowing, it might prevent the distro from booting again, in worst case. Always double or triple check before you apply the changes. Of course when you have a Live CD of Linux you can boot from CD and fix what you accidently broke. There’s always a way outside the distro to put things back, but it’s better not to mess them up in the first place. :slight_smile: