How to associatе Ktorrent and magnet link ?

I tried this

in Firefox about:config add this /usr/bin/ktorrent
network.protocol-handler.expose-all true.
network.protocol-handler.expose.magnet true
network.protocol-handler.external.magnet true
network.protocol-handler.warn-external.magnet true

Yet the answer is:Firefox cant open protocol magnet…
Also google no suggestions…
Any ideas?

If you really are on 12.1 and FF 10.0.1, you’re probably going about it wrong (undo everything you’ve described). I think you’re following instructions meant for FF 3.5.

Frankly, I’m not sure how/why magnet links are working for me, for the longest time (I think still on FF 3.5) magnet links didn’t work, then all of a sudden they’ve been working automatically for me since <maybe> FF 3.7.

Since my upgrade to openSUSE 12.1 and FF 10.0.1, magnet links have “just worked” for me. Although I remember magnet links pointing to Ktorrent before my upgrade were working, I’m personally using Deluge today (much more happy with machine resource management, block list support, etc with relatively few features missing compared to ktorrent). You might try Deluge and see if your problem is magically fixed.

And, my magnet link support is working without the entries you describe.


From Register protocol - MozillaZine Knowledge Base

Firefox 3.5 and above

(Works without installed Gnome libraries)

  • Type about:config into the Location Bar (address bar) and press Enter.
  • Right-click -> New -> Boolean -> Name:
    -> Value -> false (Replace foo with the protocol you’re specifying) > - Next time you click a link of protocol-type foo you will be asked which application to open it with.


Notwithstanding what you are reading, it’s not accurate. Before I posted recommending you remove those entries I checked my own system which supports magnet links in Firefox fine and those entries do not exist.

My current system:
openSUSE 12.1 (probably not relevant, as noted FF on 11.3 supported magnet links as well)
Firefox 10.0.1 (but I think that magnet links might have been supported as long ago as 3.7 or 4.0)
Currently using Deluge 1.3.3 (Although I clearly remember that ktorrent was also working on openSUSE 11.3)
KDE 4.7.2 (release 5) (although when ktorrent was used KDE was and earlier v.4)


No special plugins installed.

I’m also missing workable magnet links with Firefox.
I wonder, is it a Firefox problem? A mimetype issue?
None of the above? Then what?
How to fix?

Currently on
$ rpm -qa |grep -i torrent | sort


KDE Version 4.6.5 (4.6.5) “release 7”


Firefox -> Preferences -> Applications
Select content-type “magnet” and set the action to “always ask”. Open a magnet link and select KTorrent or ‘use other’ and browse to /usr/bin/ktorrent.

Worked for me to associate magnet links to QBittorrent

That’s how my FF is configured also.
But, I also remember that at least in FF <3.5 the setting had no effect, magnet links still didn’t work.

And perhaps a pessimistic caution for ktorrent users, although I have ktorrent installed on my system, ktorrent is not automatically offered as an option (might be manually configurable as an “other app”, maybe not).

I can only post my working configuration (as I did previously) and for anyone else who wants to try something different, YMMV.


I think you’re right, by default KTorrent isn’t suggested as an option so you have to look it up in /usr/bin manually via “other application”. I’m sticking to QBittorrent though, does have the nice KDE integration but download speeds are much more stable.

From Firefox -> Preferences -> Applications I`m not have content-type “magnet”

Then you need to register the protocol.

Register protocol - MozillaZine Knowledge Base

Already I applied these guidelines, but no result

For the people with Firefox 3.5 and later who are using ktorrent, the above solution worked perfectly for me just a few weeks ago. Obviously change “foo” to “magnet” though.

network.protocol-handler.expose.magnet -> FALSE

It is the solution!

Yep right there in the KB article I presented. So, if you already applied those guidelines. Why didn’t they work?

Thank you very much… I was having this issue on Kubuntu 12.10, and I have had this issue on MintKDE as well. The about: config firefox tweak was the key that I have been looking for.