How to arrange a nice e17-desktop in opensuse12.2

first step:

add the repo

to your system and download enlightenment/e17 with its dependencies

Then you get a functionable e17, what does not look very nice, still a lot of features missing.

Go to yast, open >software installing/removing, go to > “Anzeigen:Enlightenment:Nightly” (in german version) and mark ALL other not yet installed e-modules for install, you do not need the debug/devel-packages
Do this, you get a black/white e17 desktop with mostly all functions
To colour this up, in the repo are three e17-themes, you like to install them too.

To tune your desktop, go to

Bodhi Linux

download the themes you like and copy them to


in your opensuse-file-system

Log out/in, all choosen themes are available in e17, choosing from menu >settings >themes

To get a internet-connection, e17 plays with connmann/econnmann, what at least here does not work with a MobileBroadband3g-Modem.
So I always logged first in to KDE, established connection with plasmoid-networkmanager, logged out and logged in to e17, connection has been alive.
No more need to do this!
I do not why, but here has been installed gnome-control-center (maybe when installing lxde-desktop here, gnome is not installed)
You will find in e17menu >settings >system >configuration >network this nm-applet from gnome-desktop, which offers the airplane-modus, just choose “MobileBroadband”, click “on” and you get connected, saved this in “favourite applications”, so it is allways up by log-in

What I miss, comparing to bodhilinux, is the possibility to mix themes, saying I got theme x, having icons from theme y and fonts from theme z. , looking for a workaround
But that is not important, so happy, that e17 is working now with opensuse
Only thing to claim is that the Y/Z-keyboard-strokes are on the contraryrotfl!


More e17-artwork/themes can be found here


The link to download all themes from Bodhi seems dead.
I downloaded all themes, which come as a .deb package. To extract them with not much hassle, copy all the .deb files you downloaded to one directory, then as root (you need that to copy stuff to /usr/share), go to that directory and run:

for i in deb ; do theme=echo $i| sed -n 's/.deb//p'; mkdir $theme; mv $i $theme; cd $theme; ar -xv $i ; tar xzf data.tar.gz ; cp usr/share/enlightenment/data/themes/ /usr/share/enlightenment/data/themes/ ; cd … ; done

You can then remove that directory.

As for selecting specific things from each theme, just click the ‘advanced’ button on the settings editor and all is possible, requires a bit of patience though.

correct keyboard-settings for portuguese -not only - has to be done via yast; , I only could manage it this way, that is the suse-way

Come on, join e17!

Fast, beautiful, handsome!


You better check the factory repo (here is the 1-click install):

The nightly is for heavy developement. It might brake and you won’t have a system.
I had that problem once.
Tomas told me to install Factory.

It would appear that on Dec 28, diamond gr did say:

> You better check the factory repo (here is the 1-click install):

That’s a nice touch… I had to add the repo by the URL that somebody posted
on the enlightenment user mailing list…

> The nightly is for heavy developement. It might brake and you won’t
> have a system.
> I had that problem once.
> Tomas told me to install Factory.

It might. Though it doesn’t happen that often, and when/if it does, one only
needs a backup window manager installed to avoid an unusable system. I simply
installed the e16 package for that on my laptop where I’ve been running the
Nightly repo for a few months now… And the biggest problem I had was when a
“zypper up” gave me a new e17 version that wasn’t compatible with my chosen

And I had ‘that’ problem with the factory repo I installed on my desktop to…

Still if stability is more important than the “bleeding edge” to the OP, I’d
have to agree with your recommendation. And to be sure, even the factory
repo has more of the latest stuff than the E17 available from the repos
of most the other distros I’ve checked lately… So unless the OP is in
to compiling his/her own, then either way, opensuse has two of the best
repos from which to get e17…

Now in case the OP was thinking about themes when asking how to “arrange
a nice e17-desktop” I’ll mention that there is starting to be a collection
of recompiled themes at


There are just a lot of proper opensuse-themes available, a lot of thanks to Agust Verdegal, king of enligtenment-themes!
Have a look here:

You will find these themes also in e17/factory-repo for secure download via Yast2
There is also a facebook-side related to opensuse/e17

A lot of movement the last weeks, very developing.

Still not working is digikam, e17 simpy refuses to start it nor by menu nor in terminal, and gives a not documented failure-message, only to let you know.
In KDE digikam starts automatically when I connect my digital-camera and shows me all stuff on it, that on the same system with opensuse12.2
But that is the only thing to claim, right now.

A nice weekend


digikam now works in e17, after updating



Hi all, just to show how beautiful, fast and functional is e17 in openSUSE.
We also take this opportunity to give credit to all appropriate team “ / Enlightenment”, especially Tomas Cech for the great work they are doing.

Hope you like and enjoy e17!!!:wink:

I installed e17-desktop using the 1-click install. I logged out, but I see no option for e17? Only default, custom, KDE, failsafe, etc., but no e17. Am I missing something?

Restart the machine.
Btw, it is better to install it from the repo manually, 1-click-install seems often to be a bit buggy.


I tried that but it’s still not an option. I also tried uninstalling and re-installing.

I can see the binary so I now it’s installed:

% which enlightenment
enlightenment is /usr/bin/enlightenment
enlightenment is /usr/bin/X11/enlightenment

Can i start it manually?

I found the issue.

The enlightenment.desktop file was placed in the directory “/usr/share/xsessions”. However, the kdmrc file only looked in “/usr/share/kde4/config/kdm/sessions” and “/usr/share/kde4/apps/kdm/sessions”.

So I changed the following line in my kdmrc:





I could have created a link as well, but I thought this was safer.