[How-to] Acer Aspire 5520G and AR5007 64-bit

After two days of fighting with Atheros AR5007, ndiswrapper, and Madwifi I’ve got Wifi working on 64-bit openSUSE 11. This is the way I forced my laptop to use Wifi, even if sometimes this way seems to be weird. Anyway, it works for me and may help somebody.

After you’ve done updates on wired connection :wink: and you have added essential repos:

  1. Install Development Tools
    a) Go o YAST → Software Management → Down-left box choose “Patterns” → “Base Development” in the left window → Install all of it.

  2. Install Ndiswrapper
    YAST → Software Management → Search for ndiswrapper. Install “ndiswrapper” and “ndiswrapper-kmp-default”. Restart your machine.

  3. Download AR5211eg driver for 64-bit system
    a) Get the 64bit driver:

wget http://blakecmartin.googlepages.com/ar5007eg-64-0.2.tar.gz

b) Untar the package:

tar xvf ar5007eg-*.tar.gz
  1. Set up network with ndiswrapper
    a) Blacklist ath5k
gedit /etc/modprobe.d/blacklist

Add the line “blacklist ath5k” and save.
b) Go to the folder with your driver and do:

ndiswrapper -i net5211.inf
modprobe ndiswrapper

c) Restart computer.

  1. Install Madwifi (!?)
    This is silly, but you must install Madwifi to make ndiswrapper working. Don’t ask me why, but without this step your Wifi connection in YAST won’t be editable.
    a) Go to Build Service website and serch for “Madwifi”.
    b) Choose one-click install button for Madwifi that has AR5007eg in the name and has version for 64-bit.
    c)Restart computer.

  2. YAST → Network Devices → Network Settings (You’ll be asked if you want to modprobe ndiswrapper. Click “Yes”) → Choose your Wifi card and “Edit” → In “General” panel thick the box for non-root users; In “Hardware” panel write “ndiswrapper” as kernel module → Click “Next”, set-up your network, and restart computer.

Good luck!

Thanks for the tutorial. It almost worked. :frowning:

I got to the point where I can see the APs in the knetworkmanager, but I can’t get it to connect. So I have a few questions:

  1. Are there knetworkmanager’s logs somewhere? I can’t seem to find any.
  2. What madwifi package do I need to install? Can you please give us the exact link?

I also have something ath5k based (tplink). I tried installing ordinary net5211.inf on 64 bit system, could it cause any problems? If so where do I get 64-bit and how do I remove the old one?

I did not blacklist ath5k, I will try it now.


  1. I don’t use KnetworkManager, but the default manager on Gnome.
  2. I’ve installed madwifi-r3725+AR5007EG-2.2.x86_64.rpm (the last trunk version on build.opensuse.org)

WiFi following my instruction doesn’t work perfect. Sometimes it works, but frequently I must go to YAST and set-up network again. I hope the problem will be solved soon, because it’s really anoying. The only one distribution that AR5007 works out of the box is Mandriva in 32bit version.

seem the link is broken to me somehow

are there some other places I can get the driver.:frowning: