How to access the second partion on Suse live USB

I successfully created a Suse Live on a USB flash drive based on the instruction at Live USB stick - openSUSE.
I also created the second partition with the instruction on the same page but I don’t know how to access the second partition when my computer is booted up with Suse live on a USB memory stick.
The USB stick is recognized as /dev/sdh on my desktop and there are two partions.
Right after partitioning the USB stick my desktop which is running another Suse 11.2 recognizes both partitions as CDROMs.
I can mount the first partition but not the second one. There is an error saying either there is no file system or unsupported file system.
So I created ext3 file system on the second partition. After this I can fully access the second partition when the stick is plugged in to my desktop.

However, if I start my laptop computer with this Live USB stick for a test I cannot have access to the second partition on the memory stick. The second partition does not even show sup with ‘df’ command. I can see there are two partitions with ‘fdisk’ command.
Please don’t tell me to try USB live on my desktop since my desktop cannot boot from the USB memory stick.

Followings are the result of those two command

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/loop0 5580480 2436464 3144016 44% /
udev 515012 320 514692 1% /dev

Command (m for help): p

Disk /dev/sdb: 4009 MB, 4009754624 bytes
64 heads, 32 sectors/track, 3824 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x651d5702

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 678 694272 83 Linux
/dev/sdb2 679 3824 3221504 83 Linux

Note: after booting my laptop with USB live the memory stick becomes

Here is the result of ‘mount’ command I tried.

linux:/home/linux # mount -t ext3 /dev/sdb2 /home/linux/Documents
mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Here is the result of ‘dmesg | tail’
2121.114511] VFS: Can’t find ext3 filesystem on dev sdb2.

It is very odd to see the above error because I created ext3 file system already from my desktop. The above error persists even if I create ‘ext3’ file system again after I boot up with USB live. I even tried creating ‘vfat’ file system but the result is the same; cannot mount it.

What am I missing here? I really appreciate any help.

When you use a LiveUSB with a second partition, openSUSE uses the 2nd partition for storing configuration data. I am not sure what file system it creates there for that.
May be you can find out. After booting with the LiveUSB, do a proper shutdown. Now insert that stick to your desktop and check the 2nd partition.

Thanks syampillai for your reply.
It seems some how Live USB mount the second partition to /home but hide all the mount information. I can save data under /home/linux directory and it remains even after I restart. However, I still cannot access the second partition if I plug the USB stick to another computer. It is very weird but I guess there is a reason for doing that. It is little cumbersome to copy data from/to the second partition but at least it is workable.