How stop screen from turning off?!

I have openSUSE 11.3, KDE 4.4.4. In Power Management, I have everything set to “do nothing.” Under “Screen Saver” I have everything unclicked. Yet, after a while my screen STILL turns off! Can someone help me figure out what’s doing this?

I had trouble with this back then.

Can you do this:
SUSE Paste

On 06/17/2011 09:06 PM, 6tr6tr wrote:
> Can someone help me figure out what’s doing this?

some ideas:

  1. in some “green” systems there may settings in the BIOS which may be
    setup to detect “nothing happening” and kick in and shut down the screen
    after xx minutes… [by the way, you say “after a while”, can you be more
    precise, is it always 30 minutes, or ???]

  2. there used to be (i don’t remember if so in 11.3) a trick where it
    was necessary to leave “power devil” in control and set the time to 0
    rather than any number greater than zero…

  3. xscreensaver is an application in addition to the KDE saver, have you
    maybe used it somehow? (i wouldn’t know how, see ‘man xscreensaver’

  4. this has helped others in these fora, maybe it will help you:


Well, my GUI looks a little different from that but yes, that’s what I did. Here’s the three tabs:

On 06/17/2011 09:06 PM, 6tr6tr wrote:
> Can someone help me figure out what’s doing this?

in the Power Management settings, on the Performance > Screen tab, add a
check mark to “Enable Display Power Management” then

either uncheck “Standby after” “Suspend after” or “Power off after”

or check each and set the time to “0 min”

i can’t tell you which because my screen is different from yours and i
don’t have those settings any longer…and my “Help” section does not
describe which to do (nor if ‘0’ means never do this)…but, your Help
section should…

here, this posting talks about it
and is what i mentioned in number 2 of my earlier post…and, there are
other posts in that thread which are interesting and informative…

21 June: Sunrise 4:34 AM, Sunset 10:03 PM

im betting its the screensaver kicking in, go to control center, and disable the screen saver, or set it to a longer time and see if it helps.

See if this thread helps.

Specifically DPMS is usally enable by default. It can be disabled like this

xset s noblank -dpms

To query status

xset -q

Automate it by adding to a script in ‘autostart’ if necessary.

Sounds like the kernel screen blanker. xset should solve the problem.