How much in general does the upgrade from 11.1 to 11.2 ....

clobber the original system? I’ve never attempted an upgrade before. I have 11.2 on a DVD if that matters.

Does the upgrade (not installation) leave some of the old stuff alone, like user config files, etc. Or does one need to go through lots of re-config after the upgrade.

I have a fairly vanilla, and working well, 11.1 system now. No multi-boot, etc. I would like the same after the upgrade.

And yes I understand the answer “it depends”. :wink:

IMO do a clean install. All those old config files may cause a problem. Just DON’T format the home partition and you will keep all you user settings and data.

What graphics do you have on your system ? 11.1 will be supported until a number of months after 11.3 arrives.

You may wish to support who well 11.2 supports your graphics before updating to 11.1. In some cases 11.2 provides better graphic support than 11.1 and in some cases worse, so it is likely worthwhile checking first. Dependant on your graphics you may wish to wait for 11.3.

Thanks for the reply.

Graphics card: nVidia Quadro FX 570

Working fine with 11.1. Wonder why a newer version would take that away? The working fine part, that is.

I aways find it useful to boot from a liveCD, in this case one of the 11.2 live CD’s to see how well hardware is detected,

And how the system works in general. I would do this before either upgrade or fresh install.

Thats nearly what I was writing, too, but dvheny was faster.

  1. Test openSUSE 11.2 via live CD (or live CD on USB stick if this is faster?).
  2. Make one or two copies of the 11.1 “/” installation (via Yast>System Backup and a full copy via Knoppix CD etc.?).

Have you looked for (“openSUSE 11.1” OR “openSUSE11.2”) AND “nVidia Quadro FX 570” in the net and especially in novells bugzilla?

Greetings
pistazienfresser

I would have to research to be certain, but in your case with nVidia hardware it should be fine.

In the case of users with ATI Radeon hardware, ATI decided to stop support of legacy hardware (as defined by them) and that mean that version 9.3 of the ATI catalyst driver was the last version that supported legacy hardware. However the 9.3 version of the catalyst driver only works with older kernels (such as are on openSUSE-11.1 with the 2.6.27 kernel). The proprietary ATI driver does not work with legacy hardware on openSUSE-11.2.

That meant that users of “ATI legacy hardware” have to rely on the open source drivers (radeon and radeonhd) and unfortunately the openSUSE-11.2 implementation of those drivers was not the best. openSUSE-11.3 (still in milestone testing) actually has a much better open source radeon driver and ATI legacy hardware users should be much happier with that openSUSE version (as opposed to 11.2).

Again, your case with nVidia hardware should be ok.

Don’ t now if it is possible to make a scientist proof but this speaks for no problems with a graphic with a “M” (a mobile sister?):
Intel 4965 doesn’t work on OpenSuse 11.2 - openSUSE Forums

Greetings
pistazienfresser

Good idea to test with the 11.2 LiveCD. So I did.

Worked fine. Graphics worked. System recognized the video card as a nvidia Quadro FX 570. Me thinks it’s OK.

I’ll move on now to upgrading from 11.1 to 11.2 and check for smoke along the way.

Hope this might help others along the way.

Today I decided to upgrade from 11.1 to 11.2. Booted the DVD and all looked ok until…

I got to the screen entitled Installation Settings

Under Update Options - Gnome did not appear. KDE4 and lots of other stuff did but not Gnome. I didn’t want to proceeed further.

My 11.1 system has both GNOME (v 2.6) and KDE4 installed and they both work fine. I’ve kept up with the latest updates, etc. No problems.

Anyone hazard a guess as to why Gnome didn’t appear in Update Options?

And before anyone suggests doing an install rather than an upgrade, I’d like to do an upgrade and let people here know that it’s ok to do an upgrade. Really.

Once I understand what’s going on with Gnome, I intend to go down the upgrade path once again.

Are you sure you used the DVD and not a KDE CD?

Well, I downloaded the 11.2 s/w from the OpenSUSE site and upon booting the DVD it said OpenSUSE 11.2 in more than a few places.

Was gonna provide the link, but it appears to be unavailable at the moment. It’s the “Get It” box on the openSUSE home page.

Thought you said you tested with a live CD. If so did you get the disks mixed up?

You can install from a Live CD but by default it will only present you with the desktop it has ie a KDE live CD will have only KDE on it.

If you install via the DVD you will get a screen asking which desktop(s) you want.

I did test with the Live CD. It worked fine. Big item was to check if it recognized my video card, which it did.

I’ll try booting the DVD again and tell it to upgrade rather than install. I suspect I’ll get the same results.

Will post results here.

You really want a new install. The DVD will present the desktop selection screen.

Tried the upgrade again - same results. Wasn’t surprised.

This time around I clicked on Package Options and a familiar YaST screen appeared that did have GNOME listed. I read where KDE is the default desktop in 11.2, so maybe that’s why Gnome didn’t appear in Update Options? Anyway, I clicked on GNOME and a pop up window appeared with the following message:

problem with installed pkg Kernel-default-base 2.6.27.45-0.1.1.x86_64

below the message were 2 radio buttons which one could select either keep the above kernel-default-base version or the kernel-base. Both were the same version mentioned above.

Not knowing what to do, I aborted the installation.

If there is a problem with the installed pkg Kernel-default…
I sure don’t notice anything while running 11.1 and it’s been well over a year since I installed it.

Oh and I did check installation media before attempting the upgrade – No errors

Ok one last time I’m going to recommend you do a fresh install rather then an upgrade. Just don’t format the home partition and be sure it mounts as /home.

Really I have never ever seen a good upgrade path for any OS, unless you up grade to newer after a fresh install of an older. Over time OS’s collect all sorts of things and no automated installer is going to be able to handle all situations.

I will probably take your advice now, although I wonder why there is even an upgrade choice, given the potential problems.

And for completeness, since the OpenSUSE download site link is working today, here’s the place where I downloaded the DVD for 11.2:

Software.openSUSE.org

I typically always do a clean install.

Having typed that, some users ‘swear’ by the upgrade choice. I think a lot depends on how much one diverges from a nomninal “as packaged” installation in terms of 3rd party packages. I install many 3rd party packages which makes an upgrade difficult.

Plus, in some cases there are drastic changes in terms of the file system (such as from Reiser to EXT3 and then from EXT3 to EXT4) and these are issues that an upgrade does not address well.

I re-read the 11.2 upgrade material - Chapter 14 in the 11.2 Reference doc - and there was mention of: “add repositories to make sure to get all available software updated whenever possible”.

I didn’t add any 11.2 repositories when I attempted the upgrade. Was I supposed to?