How may I successfully insert a table in a document into an openSUSE, online “forum” posting?

In a 64-bit, openSUSE, Leap-15.3, Linux operating system, which was installed as a Virtual Machine (VM) in Oracle (Corporation) VM VirtualBox, in the application LXTerminal in the Lightweight X Windows system, version 11 (X11), Desktop Environment (LXDE) I entered the command

zypper repos

and received a table of repositories as a “response.” That table could be copied and “pasted” into a preparatory letter body or form for entering a posting in an openSUSE online “forum”. Then after clicking on the software “button” labeled with “Submit New Thread” that table was gratefully displayed well in the resulting online posting with its columns and rows of entries generally looking well-aligned.

But recently I have not found a way to be that successful in inserting a table into an openSUSE, online “forum” posting from a LibreOffice, .doc Writer document of the type “Word 97-2003” in my 64-bit, Windows 10 Home Edition operating system. The extension .doc is also a common extension for Microsoft Word documents. In Writer one can click on the “Table” “menu” item; select “Insert Table”; and then choose the numbers or rows and columns one wants in a table in order to insert a table into a Writer document. I could copy and “paste” a table from a Writer document into the preparatory form for posting in an openSUSE online “forum”. And that table’s columns and rows looked well-aligned in that preparatory form. But after clicking on “Preview Post,” the resulting “table” no longer looked like a table with regard to aligned entries. And there was no difference in the result of “Preview Post” after I clicked on software “button” with WYSIWYG (What You See Is What You Get) or “Remove Format” in the context-sensitive “menus” for two software “buttons” appearing on the left-hand side above the preparatory form; but there was a difference in the appearance of the data in the preparatory form depending on which of those software “buttons” had been clicked or the action of which was in effect.

I tried a second method. In that method again I had copied and “pasted” the contents from my .doc Writer document into the preparatory form. Then I tried to custom-produce a table within that preparatory form by using the spacebar and “Enter” keys of my computer keyboard to produce the spacings between the column entries and rows of a column until I had what looked like a table containing horizontally and vertically aligned entries. But after clicking on “Preview Post” my result again did not appear like a table with regard to aligned entries. So after failing in two attempts to post a table containing well-aligned entries into an openSUSE, online “forum” posting, I at least temporarily gave up on making a posting from text including a table saved in a Writer, .doc document.

Some ideas I have not recently explored toward the goal of producing a good-looking table in an openSUSE, online “forum” posting:

  1. saving a Writer document containing a table as a text, or .txt file instead of as a .doc file;

  2. using my computer keyboard’s “Tab” key in the Writer document;

  3. using the Windows applications Notepad or WordPad or the Linux application KWrite, if it is possible, to produce a table in a file using any of those applications; and/or

  4. from my first paragraph here to “paste” into a plain text document in Notepad, WordPad, or the Linux application KWrite the contents of the computer clipboard obtained from copying into it the output of

zypper repos

after entering that command in a terminal computer program, which in my case in my openSUSE, Leap, Linux operating systems has often been LXTerminal. In this way one could hope to see what characters would appear, such as spaces, Arabic numerals, Latin letters, tab characters, line-feed characters, Byte Order Marks (BOM), et cetera. Afterward one could try to reproduce such a successful method in generating other tables in a document in Writer, Notepad, WordPad, or some text editor and later to copy a table from such a document into the preparatory form for posting in an openSUSE, online “forum” posting.

Of course “trial-and-error” exploring like this could take some time. Instead hopefully someone already knows how to produce a table containing well-aligned entries in an openSUSE, online “forum” posting beginning with a text file containing a table in some text editor and is willing to post his related knowledge here for the benefit of not only myself, but also potentially for the benefit of other readers.

Anything you do to create a pure plain text file in which the content lays out as you wish in any kind of plain text viewer or editor in a monospace font will display the same way in the forum if pasted in between code tags]( (via the # icon above the input window, or manually using [noparse]

[/noparse] before & [noparse]

[/noparse] after your paste). At least, that’s how it’s always been for me. I suppose there may be clipboards that foul the paste process. Usually I use mcedit or fcl editor to create what I will copy to clipboard for pasting, but apps that can print to a .prn file do nicely as well.

#  | Alias                            | Name                      | Enabled | GPG Check | Refresh
 1 | Jun_tumblweedrpm                 | Jun RPM                   | Yes     | ( p) Yes  | No
 2 |    | Main Repository (NON-OSS) | No      | ----      | ----
 3 |        | Main Repository (DEBUG)   | No      | ----      | ----
 4 |      | Main Repository (Sources) | Yes     | (r ) Yes  | Yes
 5 |      | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes
 6 | | Main Update Repository    | Yes     | (r ) Yes  | Yes
 7 | openSUSE-20211016-0              | openSUSE-20211016-0       | No      | ----      | ----
 8 | openSUSE_Tumbleweed              | KDE Extra                 | Yes     | (r ) Yes  | Yes
 9 | openSUSE_Tumbleweed_1            | Graphics                  | Yes     | (r ) Yes  | Yes
10 | packman                          | packman                   | Yes     | (r ) Yes  | Yes

Thank you, poster mrmazda, for kindly taking some time to post your helpful reply to surround a table with code “tags” by clicking on the # symbol with the table selected or highlighted in the preparatory form or edit control for posting a posting in an openSUSE online “forum.” As for conram’s posting in this “thread” of postings I suppose he was just demonstrating how entries in a table could be well-aligned after highlighting or selecting a table and posting it between code “tags.” Assuming so, thank you, poster conram, for also kindly taking some time to post some content here. I discovered that I did not always have a good-looking table in that form after “pasting” content from a LibreOffice, Writer, .doc file. Perhaps the outcome might have depended on which software “buttons” were in effect above that form or edit control. But after some such “pastings” eventually I had a good-looking table in that form with code “tags” surrounding it. Then after clicking on “Preview Post” gratefully I had a good-looking table.

Sorry, in my first posting in this thread of postings I neglected to mention that I had placed the output of the command

zypper repos

between code “tags” in the preparatory form or edit control. That was the difference between my success with that preparation of the output of that command and my failure in attempting to prepare a posting including a table from a LibreOffice, Writer, .doc document. I should earlier have realized that difference between my two “experimental” results!