How keep NumLock turned on between restarts for USB keyboard?

I have a USB keyboard and everytime I start up openSUSE, it’s turned NumLock back off. Is there any way to keep it turned on by default?

I found the answer! A fix for Start Numlock on KDE startup in 4.2.1 release108

Any idea why this is not a setting in desktop config anymore?

Ask them at KDE, they have also a forum: Index page • KDE Community Forums.

There’s a setting there in the “input devices” configuration (personal settings) in KDE 4.6.0 (openSuSE 11.4).

I have it set at the default (don’t change numlock) because my BIOS settings turn it on anyway. But there’s a setting to make that permanent.

If you use kdm, edit the file /usr/share/kde4/config/kdm/kdmrc. Search for the line Numlock=off and change that to Numlock=on.
This will activate the numlock in the login manager.
For KDE, you can set this in the Desktop Config settings in KDE itself.

To have the numlock activated systemwide in the console, start Yast and open the sysconfig editor. Go to HARDWARE/KEYBOARD and set KBD_NUMLOCK to yes.

Now the numlock should be activated in all occasions.