How I Fixed Ugly Fonts in KDE 3.5

I recently installed 11.1, choosing KDE 3.5 as my desktop.

I was immediately struck by how awful the fonts looked, very jagged and
rough, like I remember fonts looking in ancient versions of Linux I
installed in the late 90’s.

I was sure that once I installed the Nvidia display driver, things
would improve, but this did not seem to help at all.

I went into YAST to make sure all the font packages were installed, and
I saw nothing obvious missing. So I shrugged it off and resigned myself
to looking at ugly fonts for the next six months until 11.2 is

Yesterday, I installed the Gnome and KDE 4 desktop packages, and after
I did this, logged out then logged back in, my fonts looked A LOT

Apparently if you only install KDE 3.5, some program gets left out
causing very ugly fonts. It might be the Adobe ICC profiles, but I’m not

So if you are experiencing this problem, just install the KDE 4 and
Gnome desktops, and things should look much better.


foresthill’s Profile:
View this thread:

Take a look here,

‘Optimal Use of MS TrueType Core Fonts for a KDE Desktop on SuSE -
openSUSE’ (

-“Those who would give up essential Liberty, to purchase a little
temporary Safety, deserve neither Liberty nor Safety.” – Benjamin

cygnuslodge’s Profile:
View this thread:

I set mine to Liberation sans exclusively except mono

set anti-aliasing enabled

configue sub pixel enabled - RGB - FULL - But No exclude range

But you have to fiddle a bit depending on your Box/Lap

Box: Linux x86_64 | OS 11.0 | (KDE4.1.85) “3.1” | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: OS 11.1 | Celeron 550 | (KDE 4.1.85 “release 3.1” | Intel 965 GM |
Lenovo R61e | 1GB RAM

caf4926’s Profile:
View this thread: