How I FINALLY Installed 11.2 on my ATI 200M System

After about 3-4 days of truly epic battles with the Suse Gecko, I finally have found a way to successfully install 11.2 on my laptop.

Previous attempts seemed to go fine until the first boot up, at which time I was greeted with a black screen. Trying to boot up in failsafe mode displayed the most horrific collection of error messages I have ever witnessed. And if by some miracle I was able to get to a log in prompt, my password would be rejected as “incorrect”. >:(

So what I did was boot up to the 64 bit install disk, and format my partitions and for desktop environment I choose the last option, “minimal text mode”.

When the installation finished I logged in as root and tried to run sax2 to set up my display driver, but found that sax2 had not been installed so it would not run. So I ran the following command, logged in as root:


This started YAST in a funky mouseless “circa 1990” looking environment. After much trial and error and tabbing around, I was finally able to find “patterns” and selected to install the KDE4 and Gnome desktop environments. Since I did not have a working internet connection yet, I installed the programs from my install disc.

Then when I exited YAST, I ran the following command:

sax2 -r -m 0=vesa

This command installed the VESA driver instead of the dreaded Radeon driver that came with 11.2 has been causing almost everyone with ATI graphics so many problems.

I ran sax2 and saved my settings then typed:


System rebooted, IIRC, to the text prompt. but I ran this command to get a desktop:


The desktop looked awful, but I at least had a GUI. Then I fought for half a day to get my wireless broadband card working but this is another story). I also installed the KDE and Gnome login screens so that next time I started up I would have a log in screen.

Then I went to YAST/Software/Software Repositories and added this repository

Index of /repositories/X11:/XOrg/openSUSE_11.2

Then I went into YAST / Software Management, let the repos refresh and did a search for “radeon” and installed the newer driver dated 11/24.

Then I went to the terminal, and ran the following commands


(entered root password)

init 3

(system went into text mode and I logged in as root and ran)

sax2 -r -m 0=radeon

I saved my settings and rebooted, but was greeted with a black screen, but I ran the sax2 command a couple more times until it finally “took”.

So, after about 12 hours of work, I had Suse 11.2 up and running. YMMV.

Glad to read you finally succeeded.

If you ever decide to re-install, may I suggest an alternative approach?

When installing, at the very first green installation menu, select F3 and go for the TEXT install. Then do a proper installation of KDE4. When the TEXT install is complete, it will try to boot to the KDE4 gui, and it will likely fail and give you a black screen. Just press <CTRL><ALT><DELETE> twice to reboot (or if necessary press the OFF switch for a power down/up) and reboot.

This time when you reboot, press “3” (to boot to run level 3) and select the normal default boot option. This will take you to a text login. Login as a regular user, and then type “su” to get root permissions.

(1) If you have a wired connection, then type “yast” to get the text version of yast. Navigate to software repositories and ADD the repository

then install mesa, xorg-x11-driver-input, xorg-x11-driver-video and xorg-x11-driver-video-radeonhd from that X11 : XOrg repos. Then try:

sax2 -r -m 0=radeon

and if it works restart your PC with “shutdown -r now” (or type “exit” and type “startx”).

(2) If you have a wireless, then instead of the “wired approach” follow your approach to first go for the vesa driver with:

sax2 -r -m 0=vesa

followed by either re-booting (“shutdown -r now”) or type “exit” (to get rid of root permissions) followed by “startx” to boot X windows, set up the wireless, and then ADD the repository

then install mesa, xorg-x11-driver-input, xorg-x11-driver-video and xorg-x11-driver-video-radeonhd from that X11 : XOrg repos. Then reboot to run level 3, login as a regular user, switch to rot, and try:

sax2 -r -m 0=radeon

and if it works restart your PC with “shutdown -r now” (or type exit and run startx).

Actually, upon reflection, if the VESA driver works, just press F3 and select VESA for the driver. After that the rest is fairly straight forward, as I think there should be no black screen upon final reboot (as it will boot to the VESA driver), and if there is, then simply follow the advice given above.

I was getting more than just a black screen when I installed KDE or Gnome. If that were the case, I could have just booted into text mode, as you suggest, and switched to the VESA driver.

But whenever I installed Gnome or KDE then tried to reboot, my entire system was utterly and completely hosed. All kinds of error messages streamed by so fast, I couldn’t even read them. And the system would freeze for minutes at a time at various stages of the boot process (e.g., “Starting HAL Daemon”.

The error messages seemed to indicate that no driver could be found for my soundcard and other devices. I also got messages indicating that there was no such user as “root” and that many differnt devices and processes could not be configured, followed by a messages saying that there was no memory left to store passwords.

So when I finaly got a log in prompt after 5-10 minutes of waiting, I could not log in even in text mode. The system could not recognize any of my usernames or passwords. And complicating matters, I do not have a wired internet connection, just a CDMA wireless USB modem.

But like a bad dream, I’m just glad it’s over. :slight_smile:

It reads to me that the attempt was being made here to 1st go to run level 5 (ie X window with KDE or Gnome) and then run init 3 to go to run level 3.

I never recommend that. If one attempts to go to run level 3 from run level 5, there is a risk that some modules will not be correctly unloaded, and one can have problems in run level 3. If instead, one types “3” in the options line of the grub boot menu, neither KDE nor Gnome will be run (ie no attempt is made to go to run level 5), but rather one boots immediately to a full screen text mode. Hence it is safer IMHO to just go direct to run level 3 from the boot.

I think that would have avoided the unpleasant effects observed.

BUT no matter, … it works now … you found a solution, and thats great news! Glad to read its working for you now.

The black screens on boot up have returned, without me changing anything. As I have said before, 11.2 keeps consistently fighting me every step of the way, tooth and nail. Life is difficult enough without a Linux distro that hates me.

I really can’t afford to invest this kind of time in a laptop I need for work, so after countless hours and days of trying to get 11.2 working on this machine I’m gonna reformat and just go with Kubuntu.

I should note that 11.2 works great on my Intel-based laptop, but as far as 11.2 on this laptop is concerned, I’m done. Thanks for all the help, OldCPU.

Here are the system specs, in case anyone is interested:

Gateway Support - MX6441 Notebook Specifications

Hey could you help me installing 11.2 on my intel based dell vostro 1510?

Best wishes and good luck !

I’m a strong believer in going with what works for one.