How get rid of kupdateapplet's popup?

When I started the computer, a small window (a box with no title bar) popped up saying “kupdateapplet: New Software updates for your system are available. More…” I clicked on it and nothing happened. I then clicked on the kupdateapplet to have it check and it found no updates. And now the window won’t go away and it’s on top of everything. I’ve tried to look for it in “ps -A” but have no idea which one it is. Can someone help me kill this window?

I tried xkill (the cursor with the skull + crossbones), but it does nothing.

Do you have the green gecko (updaterapplet) showing up in the notification area in the panel? Right click your mouse in the updaterapplet icon and use the options.
Maybe you can disable it to autostart and manually do the update.
To disable automatic update:
In terminal as su
/sbin/yast2 online_update_configuration

Yeah, but that’s not the problem. The problem is there’s an “always-on-top” window that’s covering part of everything I run!

Can you please explain more what’s that covering.

OK, here’s where I’m at now:

  1. I logged off (openSUSE)
  2. I logged back in
  3. The popup showed up again and then disappeared after a few seconds (yay!)
  4. It said I have updates (it says this everytime I start the computer)
  5. I clicked on the icon and it popped up a window that queried for updates
  6. it says I have no updates!

What could be doing that?

Try looking here, and following all the links KDE Updater Applet - openSUSE

I get this: every time I start up and then after clicking on it, it says there’s no updates.

I have openSUSE 11.1 and KDE 4.1.3

I am not using the updater coz I do it manually, but if memory serves it works if you choose in yast2-local security-miscellaneous settings-file permissions,
select “easy

I’d be willing to bet, you haven’t configured the updateapplet. I gave the above link in my previous post not just for the pictures, but so you could read, and follow the various links. I counted 5 links.

Now, if there is something in those pages that you don’t understand, fine. But please take the time to read. I’ll be happy to explain in more detail, if you need it, once you have read.

I also typically update manually. I don’t rely on cron jobs, and I certainly don’t like the idea of automatically updating my system. I do realize that you can set the updater to just notify you that updates are available, but then I’m back to cron jobs. Don’t like 'em. I use YaST/zypper or smart.

What are you talking about? This page: KDE Updater Applet - openSUSE has only three external links:

Libzypp - openSUSE
PackageKit - openSUSE
GNOME/Updater Applet - openSUSE

NONE of them tell you how to properly use or configure the update applet.

right click applet, un-check automatically start updater on login.