How does one integrate Flatpaks and Snaps into GNOME Software?


I’d like GNOME Software to show packages available as Snaps and Flatpaks as well as those available from ZYpp repositories. I know it should be possible as Fedora has Flatpaks shown in GNOME Software, while Snap packages are shown in GNOME Software on Ubuntu 18.04.

I have flatpak and snapd packages installed, along with the Flathub repo added (so Flatpak actually has some packages to install), yet neither Flathub packages nor Snap packages are shown in GNOME Software.

Thanks for your time, is your friend. If you don’t have it as part of your bookmarks, you should!

Go over to that link and type in any of the software you are looking for. It took me less than a second to find flatpak.

I don’t mean a package for flatpak itself, I have one installed already, I mean programs packaged in the Flatpak format. Do you know what Flatpak and Snap are? They’re cross-distro package formats, I want GNOME Software to be able to search for applications packaged as them.

I may be wrong since I don’t use Flatpak,
But it’s my understanding that apps are built as cross-distro apps, not specific to any Desktop.

If you’re looking for Flatpak applications you can install,
I’m pretty sure you can browse the apps through the Flatpak website at the following link


Folks, I really do appreciate your attempts to help but I know of these websites, I know I can use them, but that is not what I asked for, what I asked is how to do so with GNOME Software. Please do not take offence to this, I really do appreciate that you’s are trying to help, but frankly when you’re looking up these formats it’s pretty hard to miss the links you’s have given me, so I know how to search for these packages in my browser, but what I want is to do so in one place, GNOME Software. Searching in the browser is not what I want as you have to look at a few different sites (one for Flatpaks, another for Snaps and another for packages belonging to my distro, Tumbleweed), I’d rather be able to search for them all in one place, GNOME Software.

To begin with, I am not a Gnome user, thus I have no precise understanding about what “GNOME Software” is.

I think I understand a bit of the confusion above. I also think that the conclusion the OP should come to is that apparently not many people here use “Flatpaks and Snaps” (whatever they might be). Gnome users on openSUSE, like other openSUSE users, use YaST and or zypper to manage software and their repositories.

Thus, how interesting your question may be, I am afraid that you are more or less on your own. We can still hope that fellow “Gnome Sofware” and/or “Flatpaks and Snaps” users may tune in here of course though.

Thanks and sorry I sort of assumed everyone would know what GNOME Software is, or would be able to surmise what it is from a quick Google/DuckDuckGo/w/e search. But I’ll do what I can to clarify what it is. GNOME Software is a graphical front-end to package management that is developed as part of the GNOME Project. It can serve as a front-end to most package managers, including openSUSE’s ZYpp, along with the cross-distro package formats Snap and Flatpak. I’ve even used to install some apps on Tumbleweed. It, like most GNOME Software, is designed with simplicity and ease of use in mind. It is used as the default graphical front-end to package management for both Fedora and Ubuntu. Here is what it looks like on Tumbleweed (with my own custom theming):

. I usually stick to command-line package management on most distros, but GNOME Software makes it easy to search categories of software for some that I might like, I also like the pictures and the fact it can show me what’s I can install using package managers other than the one my distro uses.

Thanks again to everyone responding to this thread, I do appreciate you all contributing your time and patience to help me with this query.

First, thank you to the OP for asking this question. I certainly cannot help you solve the problem, so I provide you no benefit. However, you did provide me some benefit in asking the question. The reason is I believe each linux distribution has its own unique philosophy that drives the decisions around what is included. It is the reason I like openSUSE. If you are curious where SUSE is around flatpak/Snap then this is a good video (the reasoning around SUSE begins at 29:45):

An interesting point to make is that toward the beginning of the video Richard Brown makes the point that Canonical drives responsibility of this technology back to the developer of the software package. The SUSE philosophy seems to currently be that the responsibility should lie with the distribution.

Again, thank you for helping me understand this technology better.

Having followed the official instructions on I can see flatpak packages like Spotify in GNOME Software.

flatpak remote-add --if-not-exists flathub

fails for me, gives:

(flatpak remote-add:3796): GLib-GIO-ERROR **: 20:18:57.650: No GSettings schemas are installed on the system
[1]    3796 trace trap (core dumped)  flatpak remote-add --if-not-exists flathub

I thought I had this repo added but given this error I’m suspecting not. I’m on Tumbleweed, are you kkirill?

I guess(!) that Gnome Software is a front-end to PackageKit. Like the Update applet in KDE is.

Specially in KDE, using the applet in Tumbleweed is discouraged because it uses the equivalent of zypper up to update and that should not be done in Tumbleweed (use zypper dup instead).

Further the usage of PackageKit isn’t very much done by most openSUSE users I assume. Either YaST > Software or zypper has proven as being fit for it’s tasks since a long time and are for many (YaST also for it’s other system management tasks) one of the main reasons to use openSUSE.

Yeah, I use oS Tumbleweed (20180427).
Please check that you have “gsettings-desktop-schemas” installed.

I had it installed, I just reinstalled and retried, got the same error. This is just bizarre…

Perhaps, it has something to do with
I would try it with Adwaita GTK theme in GNOME.

Just tried switching to Adwaita and the problem persisted. Doesn’t seem to be theme related.

Let’s check the schema then:

gsettings list-keys org.gnome.desktop.interface

gsettings get org.gnome.desktop.interface gtk-theme

Both return: “No schemas installed”

What if you had compiled them manually?

glib-compile-schemas /usr/share/glib-2.0/schemas/

Also, please check that the schema itself is in this folder.

rpm -ql gsettings-desktop-schemas | grep org.gnome.desktop.interface

Still “No schemas installed” and the rpm command returns:


so yeah that schema seems to be there, even if gsettings won’t acknowledge it.

Is “glib-2.0/schemas” in one of the directories defined by XDG_DATA_DIRS: