how do you view and use a mounted webdav server

Following up on a previous thread about webdav, I have mounted my webdav server. But it doesn’t appear in the filesystem in Konquerer or Dolphin (as root or as myself).

fstab looks like this (just the line related to webdav):

wdfs#http://localhost/webdav/ /mnt/webdav fuse allow_other,uid=0,gid=500,nonempty,username=brianf,umask=007,locking=simple,noauto 0 0

mtab looks like this after I issue the “mount /mnt/webdav” command:

wdfs\040(http://localhost/webdav/) /mnt/webdav fuse rw,nosuid,nodev,allow_other 0 0

I want to be able to read and write the webdav folder as a non-root user.

I have another question, which maybe should be in another thread, but I’ll try it here: Has anyone mounted a linux webdav folder IN WINDOWS? Does anyone know how to do that? It’s so easy in Mac OS X and just doesn’t work in XP or Vista when I try to “Map Network Drive”.

fogelfish wrote:
> Following up on a previous thread about webdav, I have mounted my webdav
> server. But it doesn’t appear in the filesystem in Konquerer or Dolphin
> (as root or as myself).
>
> fstab looks like this (just the line related to webdav):
>> wdfs#http://localhost/webdav/ /mnt/webdav fuse
>> allow_other,uid=0,gid=500,nonempty,username=brianf,umask=007,locking=simple,noauto
>> 0 0
> mtab looks like this after I issue the “mount /mnt/webdav” command:
>> wdfs\040(http://localhost/webdav/) /mnt/webdav fuse
>> rw,nosuid,nodev,allow_other 0 0
> I want to be able to read and write the webdav folder as a non-root
> user.

Well, then mount the Webdav drive in your $(HOME).
E.g. here I use in fstab:
https://webdisk.xs4all.nl/chtvanw /home/theo/Webdisk davfs noauto,user 0 0

[ferrets4me] theo:/home/theo
$ll -d Webdisk/
drwxr-xr-x 24 theo users 1592 May 28 21:04 Webdisk/

if I mount with ‘mount ~/Webdisk’ I have:
$ll Webdisk/
total 2339
drwxr-xr-x 3 theo users 96 Oct 26 2003 Mailbox
drwxr-xr-x 2 theo users 144 Jun 30 2006 News
drwxr-xr-x 6 theo users 232 Feb 2 2008 WWW
-rw-r–r-- 1 theo users 429665 Apr 29 22:08 bookmarks.html
drwx------ 2 theo users 64 Sep 4 13:22 lost+found
drwxr-xr-x 3 theo users 320 Nov 20 2007 mail
drwxr-xr-x 4 theo users 144 Dec 28 2007 rdbackups
-rw-r–r-- 1 theo users 294 Apr 4 2003 ssbv0039.pub
drwxr-xr-x 3 theo users 304 Aug 26 22:52 tmp
-rw-r–r-- 1 theo users 1960105 Jun 20 2007 wingide2.tgz

So full read and write access.

Right now the Webdav mount should be in /mnt/webdav on your PC of course.

Btw: i use davfs2, not wdfs. davfs2 seems to be be better maintained.

> I have another question, which maybe should be in another thread, but
> I’ll try it here: Has anyone mounted a linux webdav folder IN WINDOWS?
> Does anyone know how to do that? It’s so easy in Mac OS X and just
> doesn’t work in XP or Vista when I try to “Map Network Drive”.

It is simple. It’s called a ‘web folder’ in Windows.
E.g. (first Google link)
http://www.hss.caltech.edu/help/web/webdav/accessing/windowsxp

I’ve followed your lead, but with different options. This is my fstab entry:

wdfs#http://localhost/webdav/ /home/brian/WebDav fuse rw,noexec,nosuid,noauto,nodev,user,owner,uid=1000,gid=100,umask=022 0 0

I still have a problem. When I issue the mount command, I receive an error:

brian@dev:~> mount ~/WebDav
fuse: bad mount point `/home/brian/WebDav’: Transport endpoint is not connected

This is the associated mtab entry:

wdfs\040(http://localhost/webdav/) /home/brian/WebDav fuse rw,noexec,nosuid,nodev,user=brian 0 0

An aside: I looked into using davfs2 but couldn’t find an rpm for SuSE 11.0. Do you know where I can get an appropriate rpm for x86_64?

I logged out, logged in, and immediately tried to umount and got this result

brian@dev:~> umount ~/WebDav
umount: /home/brian/WebDav mount disagrees with the fstab

Whoa! Look at this slice of my home directory listing:

drwx------ 2 brian users 4096 2008-08-28 10:33 .ssh
drwxr-xr-x 3 brian users 4096 2008-08-04 17:27 .subversion
-rw------- 1 brian users 6349 2008-08-28 10:42 .viminfo
drwx------ 2 brian users 4096 2008-08-06 23:56 .vnc
d??? ? ? ? ? ? WebDav
-rw------- 1 brian users 821 2008-09-04 12:11 .Xauthority
drwxr-xr-x 2 brian users 4096 2008-08-06 01:55 .xdg_menu_cache

BTW, just to match your fstab entry as a control, before logging back in I had changed my fstab entry to:

wdfs#http://localhost/webdav/ /home/brian/WebDav fuse noauto,user 0 0

Okay, I got it to work, as follows:

I created a fuse.conf file in /etc and put this in it:

Set the maximum number of FUSE mounts allowed to non-root users.

The default is 1000.

#mount_max = 1000

Allow non-root users to specify the ‘allow_other’ or ‘allow_root’

mount options.

user_allow_other

I’m not absolutely sure this was necessary given the options I put in the fstab entry, but the documentation says that if you want to use the “allow_other” option the “user_allow_other” configuration must be present in fuse.conf (which file didn’t even exist up to the time I created it). It turns out I decided not to use the “allow_other” option for now, but I may want to use it later.

I removed the fstab entry for the space of one logout and login so that I could remove the ~/WebDav directory. I wanted a clean slate.

Next I created a new directory called “webdav” in my home folder (I could have named it anything, but I wanted some symmetry in my fstab entry, which I put back in as follows:

wdfs#https://localhost/webdav/ /home/brian/webdav fuse owner,noexec 0 0

Then I logged out and back in. In Dolphin I right-clicked on the ~/webdav folder and chose the “Add to Places” option so that it would appear in the margin along with my other volumes. Now it’s the way I want it.

Next I’ll try your suggestions for getting Windows to mount the webdav folder.

fogelfish wrote:
> An aside: I looked into using davfs2 but couldn’t find an rpm for SuSE
> 11.0. Do you know where I can get an appropriate rpm for x86_64?

No such luck I’m afraid. The author made a binary tar for i386 and the
source is available. http://dav.sourceforge.net/

fogelfish wrote:
> Okay, I got it to work, as follows:
[fuse.conf stuff]
> Next I created a new directory called “webdav” in my home folder (I
> could have named it anything, but I wanted some symmetry in my fstab
> entry, which I put back in as follows:
>> wdfs#https://localhost/webdav/ /home/brian/webdav fuse owner,noexec 0 0
> Then I logged out and back in. In Dolphin I right-clicked on the
> ~/webdav folder and chose the “Add to Places” option so that it would
> appear in the margin along with my other volumes. Now it’s the way I
> want it.

That’s good to hear.

> Next I’ll try your suggestions for getting Windows to mount the webdav
> folder.

Not mine, Google is (y)our friend.
Good luck