How do you use wireless?

“My wireless doesn’t work”

Well, I don’t really know if it does or not. I’ve looked at the welcome posts, the wireless primer, and the getting your wireless to work, but those threads seem to talk about when it doesn’t work. I have no reason to believe my wireless doesn’t work. I just don’t know what needs to be done to use it.

I’ve been on dialup, but things were no longer working well with dialup. So now we have a hotspot and I got an USB wireless device. I tried it under OpenSUSE 13.2 and I could use the browser to the Internet. But on my 13.1, it times out.

Doesn’t something have to be setup or turned on? I’m guessing that you go into Network Settings. I have my network card and the wireless device. I click edit on the wireless. Guessing to use dynamic address. Guessing to use WPA-PSK authentication. The hardware tab shows rt2800usb for module name.

Is that it? Then it just works? What about my network card, could that be interfering? What if I want to turn wireless off temporarily?

Hardware info under wireless 802.11 n: Kernel Driver: rt2800usb

>iwlist scan
wlp0s18f2u5  Scan completed :
          Cell 01 - Address: 08:BD:43:54:BB:46
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=53/70  Signal level=-57 dBm  
                    Encryption key:on
                    ESSID:"UNITE-BB46"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000003ba46e0f7
                    Extra: Last beacon: 232ms ago
                    IE: Unknown: 000A554E4954452D42423436
                    IE: Unknown: 010882848B0C12961824
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1A0E1000FFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B070000000000000000000000000000000000000000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101

>iwconfig
wlp0s18f2u5  IEEE 802.11bgn  ESSID:"UNITE-BB46"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 08:BD:43:54:BB:46   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=51/70  Signal level=-59 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:43  Invalid misc:21   Missed beacon:0

>ifconfig
wlp0s18f2 Link encap:Ethernet  HWaddr 00:13:EF:BA:01:0E  
          inet addr:192.168.1.50  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1430  Metric:1
          RX packets:213 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20134 (19.6 Kb)  TX bytes:6626 (6.4 Kb)

>ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.100 icmp_seq=1 Destination Host Unreachable
From 192.168.1.100 icmp_seq=2 Destination Host Unreachable
From 192.168.1.100 icmp_seq=3 Destination Host Unreachable
From 192.168.1.100 icmp_seq=4 Destination Host Unreachable

cat /etc/resolv.conf
search lan
nameserver 192.168.1.2
nameserver 192.168.1.1


I rebooted without plugged into the router, but it still lists it as 192.168.1.2

Well, your iwconfig and ifconfig output suggests you have a valid connection and IP address assigned. Can you provide your routing table output?

ip route

> ip route
default via 192.168.1.2 dev enp2s0 
127.0.0.0/8 dev lo  scope link 
192.168.1.0/24 dev enp2s0  proto kernel  scope link  src 192.168.1.100 
192.168.1.0/24 dev wlp0s18f2u5  proto kernel  scope link  src 192.168.1.50 

192.168.1.2 is the router.

Can you ping 192.168.1.2 successfully?

> ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
64 bytes from 192.168.1.2: icmp_seq=1 ttl=255 time=0.427 ms
64 bytes from 192.168.1.2: icmp_seq=2 ttl=255 time=0.393 ms
64 bytes from 192.168.1.2: icmp_seq=3 ttl=255 time=0.421 ms

It is wanting to route to Internet via enp2s0. If that is not connected, you will have a problem.

If you are using Yast to configure networking, then edit the settings for enp2s0. Set it to activate on cable connect (not at boot time). Then when it is not connected, you should be able to route through the WiFi connection.

Well, that’s your gateway, and you can ping it successfully as expected. So far, so good. Can you try pinging a public IP address successfully?

ping 8.8.8.8

and by name eg

ping google.com

If the first works and the second fail, then it is a name server issue.

While connected, you could try deleting (as root)

rm -f /etc/resolv.conf

then

netconfig -f update

and check the name server entries again.

Ok, this is weird. Maybe how intended, but not sure if things are right here. I set up the ethernet in Network Settings to activate on cable connect. I also saw on the wireless this thing about using QInternet. If I change the interface from the old modem to the wireless, it acts like it’s sending data. I can “hang up” and then lose connection. Checking the resolv.conf file, it changes when I plug or unplug the ethernet cable and mess with QInternet. I’m pretty sure resolv.conf played some part in preventing the wireless with the two IP addresses before. Testing now, I think I had one time the IP ROUTE with 192.168.1.1 and the RESOLV.CONF with 192.168.1.2. And things didn’t work. Does first or last in the list make a difference? Fascinating, but really weird for me. I’m going to have to record the IP ROUTE command in case I need it in the future.

So now the question becomes, is this correctly set up, should something else be done to make it better? Should I be messing with QInternet? I see I could use it for the ethernet cable. What if there were more than one wireless connection. If this was a laptop, I would hate to go into Network Settings to set up a new network each time I went somewhere.

The IP addresses in /etc/resolv.conf are purely related to referencing the host(s) providing domain name services. The default gateway address pertains to the router that connects to the internet. Two different things, but sometimes the router provides the DNS as well (as with my home router).

So now the question becomes, is this correctly set up, should something else be done to make it better? Should I be messing with QInternet?

I only use NM these days, including controlling my mobile broadband device. However, I can still use ‘qinternet’ for treating it as a dialup device. I wouldn’t use it for ethernet/wireless connectivity.

Is Network Manager best then? I’m going to need some pointing in the right direction. Tutorial? Originally I saw Network Manager at the bottom and tried that, but nothing made sense to me, I couldn’t add a wireless connection. Besides not having a clue what I was doing. And then I heard one talk about Network Manager vs ifup and didn’t want to mess something up.

Network Manager is best suited to those frequently changing networks (as I do). ‘Traditional ifup’ is good for desktop environments, where connected network doesn’t change much.

If the wireless device is working and NetworkManager is enabled, the NM applet at the bottom should just show all available wireless networks.
Just click on one to connect.

deano_ferrari,

Since I have a desktop, I probably don’t need NetworkManager. But it would be nice to know how it works for elsewhere.

Thanks for the link to using Network Manager. I’ll have to read through that.

wolfi323,

I guess I didn’t understand what “enable” means. The link says you need to go into network settings. On my own, when I went to the bottom right and click on NM, it has a checkmark called enable networking. I click that and nothing changes. Guess that’s not enabling it?

Yes, you probably don’t really need it, but I prefer it on a desktop too, at least for wireless and VPN connections.
It also allows to configure connections as user (without root privileges).
And it has a nice icon on the desktop… :wink:

I guess I didn’t understand what “enable” means. The link says you need to go into network settings. On my own, when I went to the bottom right and click on NM, it has a checkmark called enable networking. I click that and nothing changes. Guess that’s not enabling it?

That enables/disables all network connection, but not NetworkManager itself.

You can (have to) switch between NetworkManager and the traditional ifup in YaST->Network Settings->Network Devices->Global Options.

Although on 13.1, KDE’s NM icon should actually hide itself if NetworkManager is not running.
Are you using a different desktop?

I’m running 13.1 and it’s not visible on the system tray until you click the up arrow which then lists software updater, notifications, and the Network Management.

I recall somewhere in the past that changing ifup to Network Manager in Network Settings could cause problems. Do any of you know of any issues of changing it one way and then changing it back?

Well, that would indicate that NetworkManager is not running, which would explain why you don’t see any networks or interfaces in the applet.

I recall somewhere in the past that changing ifup to Network Manager in Network Settings could cause problems. Do any of you know of any issues of changing it one way and then changing it back?

No, you must mix that up with something else.

There only can be problems if you switch the wrong way and end up with both services running. If you do it in YaST it should work fine.

On 2015-09-04 17:06, dt30 wrote:
> I recall somewhere in the past that changing ifup to Network Manager in
> Network Settings could cause problems. Do any of you know of any issues
> of changing it one way and then changing it back?

Nope. Besides network being interrupted while you change. Maybe a
restart of network, or a reboot, be necessary. Nothing dramatic :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)